+ Start a Discussion
mamta1mamta1 

Lookup filter not showing on Site public page

I have created a Site home page that allows visitors to create Tickets. Ticket has a lookup relationship with Location object. So I have put an inputField which renders as a lookup. For Location, I have enabled enhanced lookup and set lookup filters fields state, city and zip. When trying to create ticket from within my DE I can see the lookup filters after performing a search. However, from site public page, I can only see the search results and sort links, the filter fields and Apply Filters button dont show up.

 

Can the lookup filter fields be made available when doing lookup from site public page?

Shilpa_SFShilpa_SF

Hi ,

 

    Please check whether the permissions are available for the profile on the Lookup fields(object), otherwise you would not be able to view the fields.

mamta1mamta1

I have given full access to the custom object for the public site's profile. Still the filters do not show up.

krishnagkrishnag

did u check the field level security of that lookup filed make sure visible checkbox is enabled.

mamta1mamta1

I did check the field level security and the site's public profile has permission to view all fields of the looked up object.

 

I think I did not put the question clearly.

 

I do see the lookup icon on my page and by clicking it, I can see the lookup page. I had enabled enhanced lookup and lookup filter fields for this looked up object. But those filter fields do not show up in the lookup window when I get lookup popup in site public page.

Ola BamideleOla Bamidele
Hi mamta1,

Do you now have the answer to your question now as it been 8 years :D  ?  im also having the same issue. 

Thanks