+ Start a Discussion
finalistfinalist 

Dev Org, Contact Portal, 'Error occurred on VF page' - No admin emails generated

I have a single Contact enabled as a Contact Portal user, and created a login and password for that Contact.  Logging in as that user results in an error on my custom page (apparently): "Error: Error occurred while loading a Visualforce page."  No email was generated for the Administrator, though.

 

Is there a way to create a Debug Log for the Contact Portal user?  How can I identify what the VF error is, otherwise?

Best Answer chosen by Admin (Salesforce Developers) 
finalistfinalist

Hi Ryan - 

 

We figured out that there was an error on the page that had nothing to do with the login, and now (at least) a non-authenticated user can get access to the page.  I haven't retried the Portal login yet, but I suspect this addressed that as well.

 

I guess I should get used to testing these pages directly using /apex/pagename before jumping ahead to see what the user experience will be; at least then I should be able to use debug logs! ;)

 

All Answers

RyanGuestRyanGuest

What happens if you go to the page when using the customer portal (not sites). Do you see any error message?

 

Also check that you aren't already logged in as another portal user.

finalistfinalist

Hi Ryan - 

 

We figured out that there was an error on the page that had nothing to do with the login, and now (at least) a non-authenticated user can get access to the page.  I haven't retried the Portal login yet, but I suspect this addressed that as well.

 

I guess I should get used to testing these pages directly using /apex/pagename before jumping ahead to see what the user experience will be; at least then I should be able to use debug logs! ;)

 

This was selected as the best answer