+ Start a Discussion
andresperezandresperez 

Authenticated sites.

I am trying to build a site that allows users to log on and see only their data in the custom objects.
 
The documentation I have found (Force.com Developer Guide, Chapter 14) suggests that I clone the "Customer Portal User" profile. But I do not see that profile in the Setup > Manage Users > Profile. The closest profile I have is "Customer Portal Manager".
 
The only profile I can set up in de "Customer Portal" is "Customer Portal Manager" (I would prefer to use "user" rather than "manager", for security purposes), but the "manager" profile does not show any custom objects.
 
What am I doing wrong? Did I delete anything that I was not supposed to?
 
Thanks
 
Andres Perez
Best Answer chosen by Admin (Salesforce Developers) 
BulentBulent
Andres,

Please check the following:

1- Profile you created (via clone) is enabled for your portal: Setup > App Setup > Customize > Customer Portal > Settings > Click the Name of your portal. Scroll down to the Assigned Profiles related list and enable your cloned profile for your portal.
2- Portal default user profile is set to the correct profile
3- Portal default user role is set
4- Portal is enabled for self service registration
5- portal admin user is set and has a role

All Answers

BulentBulent
Andres,

When the Portals enabled for Developer Edition orgs it's enabled with the "Customer Portal Manager" Profile rather than "Customer Portal User" profile in order to give more features. The Guide should have mention the correct profile.
What you need to do is the following:
1- Clone the existing "Customer Portal Manager" profile
2- Drill down to object details Setup > App Setup > Create > Objects > Click Edit link for the object you want to enable for portal
3- Check the "Available for Portal" Check box under the Optional Features section and click save.

Now you should be able to see your custom object in the cloned customer portal manager profile.

Don't for get to enable this new cloned profile for your portal
Setup > App Setup > Customize > Customer Portal > Settings > Click the Name of your portal. Scroll down to the Assigned Profiles related list and enable your cloned profile for your portal.
andresperezandresperez
Hi,
 
I have done what you told me, but I still get poblems.
 
I am now getting this error "Your user profile is not associated with this service" whenever I try to create a user. I can see the contact has been created in the propper account.
 
Is there a checklist to see that I am doing everything correct?
 
Thanks
 
Andres Perez
BulentBulent
Andres,

Please check the following:

1- Profile you created (via clone) is enabled for your portal: Setup > App Setup > Customize > Customer Portal > Settings > Click the Name of your portal. Scroll down to the Assigned Profiles related list and enable your cloned profile for your portal.
2- Portal default user profile is set to the correct profile
3- Portal default user role is set
4- Portal is enabled for self service registration
5- portal admin user is set and has a role
This was selected as the best answer
RyanGuestRyanGuest
Andres,

The problem is your profile isn't enabled for your portal.

Go to the customer portal setup page and add the profile for the portal.

andresperezandresperez

Hi,

That was it!

This authentication process is a bit complicated in the Force.com and there are no simple documentation on how to configure it propperly. There are only bits here and there....

Thanks.

BulentBulent
Thank you for the feedback. We'll post an article on this topic.