+ Start a Discussion
studebakerstudebaker 

Browser page title not showing

My VF Sites application is working fairly well now but there is one nagging detail - the title attribute on the apex:page tag does not seem to flow into the browser.

 

<apex:page controller="SitesSearchCustomController" action="{!init}" showHeader="false" sidebar="false" title="Foo">

 results in a browser page that looks like this (note - no title appears)

 Firefox 3.0.8

 

or (Chrome):

 Chrome

 

or IE7:

 

 

What am I doing wrong?

 

Eric 

 

Message Edited by studebaker on 04-17-2009 05:57 PM
Best Answer chosen by Admin (Salesforce Developers) 
BulentBulent

Eric,

 

you have the showHeader attribute set to false. In this case you need to insert your title tag:

 

 

<head><title>my page title</title></head>

 

All Answers

BulentBulent

Eric,

 

you have the showHeader attribute set to false. In this case you need to insert your title tag:

 

 

<head><title>my page title</title></head>

 

This was selected as the best answer
studebakerstudebaker

Bulent - this worked!  Please add to the documentation for the apex: page component with respect to the title attribute.

 

Eric 

Ron WildRon Wild

Bulent -

 

When using a Site Template I often need to specify <head></head> elements in both the template and the page ... and the source for the page ends up with two <head></head> sections  ... as well as two <doctype....> tags.

 

How does the Sites server merge html elements for pages when using a site template and are there any recommendations on how to keep the resulting html output clean?

 

Thanks,

Ron