+ Start a Discussion
paul-lmipaul-lmi 

Bug: Portal CSS is included in Sites pages if the site is login-enabled

Doing a project for a customer, and they have a login-enabled site.  We're trying to use the Public Knowledge Base AppExchange package with this site, but the CSS keeps having issues.  In doing some research and reviewing the generated HTML for the pages, it's apparent that the Site is including the following snippet in every page if the site is login-enabled.  This is not including the fact that the user is still anonymous when browsing as well (the anonymous users are being forced to inherit this CSS as well).

 

<link class="user" href="/sCSS/23.0/1320195876000/PortalDefault/default/gc/elements.css" rel="stylesheet" type="text/css" />

<link class="user" href="/sCSS/23.0/1320195876000/PortalDefault/default/gc/common.css" rel="stylesheet" type="text/css" />

<link class="user" href="/sCSS/23.0/1320195879000/PortalDefault/gc/dStandard.css" rel="stylesheet" type="text/css" />

<link class="user" href="/sCSS/23.0/1320195879000/PortalDefault/00DV00000000Uh4/00530000004j8Yx/gc/dCustom0.css" rel="stylesheet" type="text/css" />

<link class="user" href="/sCSS/23.0/1320195876000/PortalDefault/default/gc/extended.css" rel="stylesheet" type="text/css" />

<link class="user" href="/sCSS/23.0/1320352245000/PortalDefault/00DV00000000Uh4/060V0000000D0Ua/gc/portal.css" rel="stylesheet" type="text/css" />

<link class="user" href="/sCSS/23.0/1320195876000/PortalDefault/default/gc/setup.css" rel="stylesheet" type="text/css" />

 

How do I make it so that this is not happening?  We include these attributes in all the VF pages and templates for the Site:

  • showHeader="false"
  • sidebar="false"
  • standardStyleSheets="false"

 

But it doesn't seem to respect that if the site is login-enabled.  When I disable the login functionality for the site, teh CSS fo rthe portal is not included, but other standard CSS is.

 

Has anyone run into this with Sites, and if so, how do you overcome it?

 

 

Pan_AKPan_AK

Can You Try the following thing And let me know if It works for You

 

 

Under the App Setup --- > click On Customize --- > Customer Portal ---- >Setting ---- > click on edit of the customer Portal ----> Under the Look and feel ----- > Remove the files from the Header and footer

paul-lmipaul-lmi

is this a proposed workaround, or just to determine what's causing the inclusion of the lines?  we need the header and footer, as this site powers Salesforce Answers.

Pan_AKPan_AK

Hi Paul

 

Yes it was to determine what's causing the issue .The css is coming from there .It is used for the header and footer css of the site pages .

 

Use the following link to remove the css dynamically

 

http://www.javascriptkit.com/javatutors/loadjavascriptcss2.shtml

 

mikefitzmikefitz

My guess is that there is a component without the standardStyleSheets="false" attribute that is hiding.

standardStyleSheets="false" works so it's a matter of figuring out where the stylesheets are not turned off from.

paul-lmipaul-lmi

All VF pages have standardStylesheets set to false.  This is a BUG, not user errror.  Verifiably reproducible when using a login-enabled FDC Site.