+ Start a Discussion
jgrenfelljgrenfell 

CMSForce: contentblock not displaying in public site

I'm sure this is a permission error somewhere, but I can't seem to find it.  I've installed CMSforce, followed the setup instructions and created a Page with a PageItem for the "body" contentblock in my Page Template.  I am able to view the page I created in my public Site, but the contentblock on that page isn't displaying with the text from the PageItem.  It displays fine in the preview, just not when viewed as a Sites page.  The public access profile for that site does have Read permission on the ContentBlockItems object.  Is there another permission setting that I could be missing that might cause this? 

 

I tried giving read access to the Page and PageItem objects, but that didn't do it. I also tried enabling all of the CMSForce VF pages for that site, but also no go.  What am I missing?

Best Answer chosen by Admin (Salesforce Developers) 
BulentBulent

CMSForce packages was not deployed and was in "development" status.

 

Administrator users can run applications with objects in "development" status for testing, but if you want others users to run these applications then the objects must be in deployed status.