+ Start a Discussion
mb2009mb2009 

Proxy problem in Eclipse

Hi everybody,

 

I just set up my Eclipse ( 3.3.2) and installed Force.com IDE (16.0). When I try to get create a new Force.com  project , I got the "Unable to fetch organization details for..."  message. It says Eclipse is not able to tunnel through proxy and proxy returns "http/1.1 407 Proxy authentication required ..."

 

 

 

my eclipse.ini  file reads like : 

--launcher.XXMaxPermSize 256M

-vmargs -Dorg.commons.logging.Log=org.apache.commons.logging.impl.SimpleLog

-Dosgi.requiredJavaVersion=1.5

-Xms40m

-Xmx256m    

 

 

I would appreciate if you could share your prior experiences.

 

Thanks in advance

 

Mehmet 

Best Answer chosen by Admin (Salesforce Developers) 
arunkarunk

Hi, 

 

Problem seems to be that you are under proxy and Eclipse is unable to route the requests through the proxy.  

Try if one of the below works for you ...

 

 

 

1) Configure Eclipe

 I am using Eclipse 3.4 but the process will be nearly same.

 Window>Preferences>General>Network Conenctions

 You can set your proxy settings here.

 

2) Use  Firewall Client for ISA Server 

http://www.microsoft.com/DownLoads/details.aspx?FamilyID=05c2c932-b15a-4990-b525-66380743da89&displaylang=en 

What this does is routes all requests through the proxy. 

 

 

Solution 2 worked for me ...

 

 

Regards,

Arun 

 

 

PS: I don't think this was the right place to ask this question. This is the "Force.com Sites" discussion section.