+ Start a Discussion
nathanael.mnathanael.m 

Sites and Ideas Only Portal Licenses

We've created a Salesforce Site, a public facing ideas section using the customer portal, and we've also purchased some Ideas Only Portal Licenses. Some of the site pages access some custom objects via the Sites guest user account. When an Ideas Only Portal Licensed user logs into the customer portal and then visits the site, those pages no longer work as designed since Ideas Only users have no visiblity to those objects.

 

Is there a way for the Ideas Only portal users to access the Site with guest permissions even if they're logged into the portal? Limiting the Ideas Only users in this way doesn't make sense, since we've effectively given public read access to the objects referenced by the Site.

 

Thanks,

 

Nathanael

 

 

Best Answer chosen by Admin (Salesforce Developers) 
BulentBulent

Did you enable your custom objects for Portals?

Drill down to the custom object definition page and enable for portal, then they will show up on the portal profiles for you to enable permissions on these objects

All Answers

Scott.MScott.M

Just a small point to think about is that the same behavior would apply to a CMSForce site that was connected to an ideas only portal. I don't know if there are any such sites that exist today but you could easily set up a test :) 

 

Cheers,

 

Scott 

BulentBulent

Ideas only portal gives you 3 custom tabs, visualforce and full crud on custom objects.

Did you experience the access differently?

 

nathanael.mnathanael.m

Thanks for your reply. We have, infact the Ideas Only Portal User profile has literally only Read and Create permissions on Ideas. Idea is the only object listed. If as you say it's supposed to have full CRUD support for custom objects then that would definitely solve the issue.

 

I'll log a case. Thanks.

 

 

 

 

nori_ideasnori_ideas
That's funny. I believe you should have access to those other custom objects.
BulentBulent

Did you enable your custom objects for Portals?

Drill down to the custom object definition page and enable for portal, then they will show up on the portal profiles for you to enable permissions on these objects

This was selected as the best answer
nathanael.mnathanael.m

That was it. Thanks!

 

Nathanael