+ Start a Discussion
hemmhemm 

Keeping a Site in HTTPS

I have a Salesforce Site that uses Customer Portal as the authentication mechanism.  For the life of me, I cannot get the Site to stay in HTTPS after the initial login.  I am entering the site using the HTTPS force.com URL.  I login successfully, but I am redirected to the site's homepage, but it's put to HTTP.  Why?

 

Once logged into the site and manually change the URL to HTTPS, I am able to keep it on HTTPS pages as I do things.  It's just the login that redirects me out of HTTPS and back to HTTP.

 

Ideas?

Best Answer chosen by Admin (Salesforce Developers) 
BulentBulent
take a look at this online help section. The Organization-Level Security: Require Secure Connections (HTTPS) must be checked and the Site-Level Security: Require Non-Secure Connections (HTTP) must e unchecked.

All Answers

BulentBulent
take a look at this online help section. The Organization-Level Security: Require Secure Connections (HTTPS) must be checked and the Site-Level Security: Require Non-Secure Connections (HTTP) must e unchecked.
This was selected as the best answer
hemmhemm

That did it!

 

Funny how I consult the forums and look at all the developer documentation (VF, Apex, Sites), but always forget to search the Help. Help definitiely has information the others should.

 

paul-lmipaul-lmi
Do the sandbox servers lack a proper SSL certificate?  I'm putting the finishing touches on a custom customer portal/sites implementation, and it'll require SSL for the whole session.  I noticed that the cs1 instance isn't using a proper cert when I use the secure URL that the sites config defines.
BulentBulent

sandbox site url for make has multiple subdomains (xxxx.sandboxname.instancename.force.com)

Site ssl certificates (*.*.force.com) doesn't support this many multiple subdomains.

 

you won't have this issue for  your production org.

MunmunMunmun

Hi can you please explain me  how to do it.where in security testing we have to  do it.

Thanks

Munmun