+ Start a Discussion
kenzokenzo 

Data Entry Fields & Radio Buttons Not Displaying On Production Server

I was (after much help from the community - thanks!) able to get my first (simple) page up on the Sandbox. It works fine and displays correctly.  In migrating to the Production Server, though, the page is not displaying the boxes for data entry, nor the radio buttons (from a Picklist) for the survey questions.  Again, this is the first page I'm moving over, so please feel free to state the obvious if it seems cogent.  Thanks!
Best Answer chosen by Admin (Salesforce Developers) 
BulentBulent

if you can post your visualforce page source code we can take a look at it. 

You only need to make visible the fields that you are rendering on your page.

Message Edited by Bulent on 03-10-2010 03:25 PM

All Answers

BulentBulent
check the "create" permission on the related object and field level security for the related fields. Sites details>public access settings.
Message Edited by Bulent on 03-10-2010 01:27 PM
kenzokenzo

Thanks for the quick response.  You're correct, there were definitely settings that needed changing. I have done the following and made some progress:

1) Followed your suggested path (Sites>details>public access settings) and now have Basic Access: Read & Create checked - as well as Data Admin: View All (for the Custom Object).

2) For the Custom Object's "Custom Fields"  I initially followed your path regarding "Set Field Level Security" and ensured some of the Visible boxes were checked. (Q: do they ALL need to be checked?). Just curious, as I also set them all to "Required" (as per the client's request) which I noticed when going back into the Field Level Security auto-marks them all as Visible.

 

So now the majority of data entry field boxes are visible. (Yea!!).

 

However, the problems I am still running into are:

1) The Custom Fields that are Picklist based are not displaying the requisite lists from which to select.

2) The Radio Buttons (based on simple Picklist of #'s 1-5) are not displaying for the satisfaction survey questions.

3) The Long-Text Area boxes are not showing (couldn't find a way to make them "Required" - which wouldn't be preferable anyway) - Field Level Security shows All Users marked as "Visible."

 

Thanks for any additional help you can offer! 

BulentBulent

if you can post your visualforce page source code we can take a look at it. 

You only need to make visible the fields that you are rendering on your page.

Message Edited by Bulent on 03-10-2010 03:25 PM
This was selected as the best answer
kenzokenzo

Bulent:  Thanks for getting me most of the way there.  I played around and was able to come up with the rest of the fix as per below:

 

Solution:  needed to go to Custom Object > Custom Field(s) > 1)Set Field Level Security (All-Visible); AND 2)View Field Accessibility (ALL Profiles set to EDITABLE).

Also, interesting to note that for a few of the Fields I needed to go back more than once and reset them.  For some reason they switched back to HIDDEN for the Guest Profile (which is the target audience of this particular visualforce page).

Thanks for community support!  

BulentBulent

You need to use the site public access settings page for any security related setup for your site.

In order to centralize the site security updates you do in other parts f the setup won't impact your site (for example when you create a new field and say enable it for all profiles, this action doesn't include sites) 

otherwise, it would be hard to control what shows up on your site when you think about delegated administration use case with multiple admins managing different objects. 

Alway, use site details> public access settings for your site security setup. 

kenzokenzo
Bulent:  Can you identify which section(s) I should adjust within that zone?  The only portion I adjusted was the: "Custom Object Permissions" which I edited to allow the Basic Access of the object in question both Read & Create capability, while setting the Data Admin to "View All".  Although I understand the need for a structure that centralizes the security, I'm not seeing the place that would allow me to adjust the visibility of the various Custom Fields.
BulentBulent

Site public access settings page has the same ui as the profile details page (subset)

you should be able to control:

object permissions, field level security, tabs, record types, ip restrictions.. via the site public access settings page. 

kenzokenzo

Sorry if I'm being dense, but the setting change that seems to have worked (from adjusting the Custom Object itself) was "View Field Accessibility" ( changing Guest License User & Warranty Profile to "Editable" ).  

 

I'm not seeing any equivalent in the Site Public Access Settings Page.  If there is a different way to get it to work through the Site Public Access Settings Page (and follow the preferred approach) I certainly prefer to do it that way. Just not seeing the way yet.

Message Edited by kenzo on 03-12-2010 10:13 AM