+ Start a Discussion
FilikinFilikin 

Error in aapt uploading Hybrid to Google Play

Hi,

I am trying to upload my Hybrid app to Google Play.

I am getting the error:

 

Failed to run aapt dump badging:
ERROR getting 'name' attribute: attribute is not a string value

 

I compared my Manifest.xml with the ContactExplorer and it looks identical.

ContactExplorer does not give this error when I pass it through aapt (using aapd d badging), but SmartStoreExplorer does.

 

Since my app using the SmartStore library, could this be a bug in the library?

Best Answer chosen by Filikin
Kevin HawkinsKevin Hawkins
Take a look at the updates on issue 430 of SalesforceMobileSDK-Android (https://github.com/forcedotcom/SalesforceMobileSDK-Android/issues/430).  Hopefully the suggested workaround will clear this up for you.

All Answers

bdPeterbdPeter
Any new developments on this? I ran into the same problem without with my app (which also uses the SmartStore) without any changes at my end in the manifest. It appears this started to happen with the latest Android 4.4.2 SDK update. Even if I pull out a previous build from source control that used to upload just fine, this error is reported.
FilikinFilikin
NO, it has got worse. I just tried it with an app that uses the Salesforce SDK and not the smartstore and got the same error
Kevin HawkinsKevin Hawkins
Take a look at the updates on issue 430 of SalesforceMobileSDK-Android (https://github.com/forcedotcom/SalesforceMobileSDK-Android/issues/430).  Hopefully the suggested workaround will clear this up for you.
This was selected as the best answer
FilikinFilikin
thanks Kevin, yes, that fixed the issue.