+ Start a Discussion
Scott0987Scott0987 

Salesforce Solutions Custom Fields not showing up on public force.com site.

I have a site that has solutions on it.  If you log into the system and pull up the visualforce page you can see all of the fields for the solutions on the page.  But if you pull up the site that is linked to that visualforce page all Custom Fields on Solutions do not show up.  I have gone through all the permissions and everything is correct as far as I can tell.  Anyone have any idea why this might be happening?

Best Answer chosen by Admin (Salesforce Developers) 
ForcepowerForcepower
Scott, Have you looked at the
Field-Level Security for Solution in the site guest user profile? Are all fields you need checked as visible?
Ram

All Answers

ForcepowerForcepower
Scott, Have you looked at the
Field-Level Security for Solution in the site guest user profile? Are all fields you need checked as visible?
Ram
This was selected as the best answer
Scott0987Scott0987

I found the solution for anyone else having a similar issue with sites.  To check the permissions I had gone to the field and clicked on field level security and then made sure that all the profiles had it set as visible.  The only thing I did not reallize is that the public profile for a site is not listed on this page.  I had to go to the site then click on the public profile and then on view under field level security.  Hope this helps someone else.

ForcepowerForcepower
Correct - it is set at the site guest user profile level.
Scott0987Scott0987

Thank you for the help Ram@4cepower.com we must have been typing in the solution at the same time.  I went ahead and marked yours as the solution.  Thanks for replying. 

ForcepowerForcepower
Hey - no problem, Scott! You're very welcome.
Best,
Ram
Jonathan Vance 5Jonathan Vance 5
I'm having a very similar problem, but Scott's solution is not working for me.

When I launch my home page from the Developer Console Preview, I can see all the fields on my custom object on all 3 of my site's pages; however, when I navigate to the url to see the public site, only 2 of my 3 pages display field data from my custom object.

Like Scott says, I went to Setup->Build->Develop->Sites and clicked on the Site Label for the site in question. From there I clicked the Public Access Settings button, scrolled down to the Field Level Security -> Custom Field Level Security area and clicked View for my custom object. From there, I see that all my fields are checked as visible.

Am I missing something? Does anyone have any other suggestions on this problem?
Peter IkladiousPeter Ikladious
Jonathan,

Your issue sounds very similar to mine.  All my fields are marked as visible, but when I run a flow, the fields "disappear" and an exception.  I have a feeling it's linked to the new Spring 2015 release.  Please advise if you were able to get this resolved.
 
Chetna AgrawalChetna Agrawal
Facing the same problem
 
Kyle LawsonKyle Lawson
In case anyone else is still having problems after setting the field level security, my fields were still not showing up and I realized that I hadn't set object level security on my objects to at least 'Read' yet for the guest user. Enabling read access allowed the fields to show up.
Francisco Riccomagno 1Francisco Riccomagno 1
I followed this solutions, and I wasn't able to still see it. I fund out that even do the public profile has visibility, to actually display it you need also to provide visibility to the System Administrator profile. Just in case someone is having this issue, check this option as well ;)
Mostafa YounisMostafa Younis
I've been struggling with the same issue. I checked the public profile and confirmed that it has View access to my custom field (so does the admin). I also checked the page layout to make sure it's visible and it is. When I visit my community page as a logged in user, I am able to see everything perfectly. However, if I try viewing it as a public guest, that custom field doesn't show up. Any ideas what could be wrong here?
Eric Li 55Eric Li 55
I had the same issue as well, and noticed the fields that weren't showing was non-required fields. I went in the fields and set them as required, saved, went back in, and unset it as required. Now the values are showing on the page. I am not too sure why that is, but if you can, give it a try?
Trace GillespieTrace Gillespie
Solved the same issue with other fields. Thanks!
BenediktBenedikt

Hi, I've a problem with custom fields on a visualforce page using the standard controller for cases. This page tests data of the current user.
Within the user record I've some custom fields, accessible for all profiles. I can show them, but can not use them in a condition. I can assign the field to a variable 'test', but if I try to show this variable, I get an error message Error: Unknown property 'CaseStandardController.test'.
With standard fields, using the same syntax, I haven't these problems. What's to do?