+ Start a Discussion
iskradeviskradev 

Force.com tutorial workbook

I'm reading Force.com tutorial workbook, tutorial #2, step 4 (Test the @future Method). The description says:

 

  1. Go to the Developer Console by clicking Your Name | Developer Console.
  2. Click the box marked Click here to enter Apex Code and enter the following code.

My problem is that I can't find any boxes with that text.

 

http://i.imgur.com/qBjHCek.png

Best Answer chosen by Admin (Salesforce Developers) 
iskradeviskradev

OK, I still have an issue. The problem is that the "order" resource of the test application doesn't respond to POST requests for some reason.

 

This is what I get: http://i.imgur.com/PgKudhw.png

 

I did double check "Setup→Security→Remote site settings" and it's fine. What am I supposed to do now?

 

UPD1: The app returns 415: http://i.imgur.com/b5d77Yy.png ( curl -X POST http://floating-brushlands-5239.herokuapp.com/order )

 

UPD2: it was a stupid mistake by me. I had to replace "http" with "https" in "Setup→Security→Remote site settings".

All Answers

Dhaval PanchalDhaval Panchal
Try below....

1. Go to Your name | Developer console
2. one Popup window will be open
3. Click on Debug
4. Click on "Open Execute Anonymous Window"
5. One editor box will be open
6. Paste your code here and click on execute.

Might be your book is old one. Now with new version of Salesforce Developer console is changed.
iskradeviskradev

OK, I still have an issue. The problem is that the "order" resource of the test application doesn't respond to POST requests for some reason.

 

This is what I get: http://i.imgur.com/PgKudhw.png

 

I did double check "Setup→Security→Remote site settings" and it's fine. What am I supposed to do now?

 

UPD1: The app returns 415: http://i.imgur.com/b5d77Yy.png ( curl -X POST http://floating-brushlands-5239.herokuapp.com/order )

 

UPD2: it was a stupid mistake by me. I had to replace "http" with "https" in "Setup→Security→Remote site settings".

This was selected as the best answer