+ Start a Discussion
Hemant PatelHemant Patel 

Enable Custom Object Permissions on Authenticated Website Profile

Hello,

 

I am logged in as System Administrator.

 

I am trying to enable Custom Object Permissions  on Authenticated Website Profile.

But when i going to edit "Authenticated Website Profile"  Custom Object Permissions is in disable mode, I can see object names in disable mode without any permission.  Please help me.

Salesforce FreeLancerSalesforce FreeLancer

1 Create clone of the your basic authenticated profile

2 Open that new profile, You can change settings of custom objects and save it

3 Now assign this new profile to your users

 

Please check and let me know if you have any problems, in this clone profile you can change custom objects permissions

 

Regards,

 

hardik

Hemant PatelHemant Patel

Hi,

 

Thanks for you reply.

 

I did the way u have told, and custom objects are enabled for permissions. However with this option Authenticated Website User getting following error when they logged in.

 

"Error:Your user profile is not associated with this service. Contact your site administrator for more information. "
Which means, I think we can't change profile against  Authenticated Website User. So my problem remain same.
Salesforce FreeLancerSalesforce FreeLancer

Do the following,

 

Create Clone of your profile and assign that profile to your current user.

Update permission for your custom objects in ths new profile.

Open Customize->Custmer portal-> select your protal and check newly created profile (add this new created profile in customer portal list)

 

Now you can access custom objects from site and you will not get any error.