+ Start a Discussion
LloydSilverLloydSilver 

Possible Bug: Dropdown List values not working with record create

I have a screen with two different dropdown lists (among other fields). The dropdown lists are:

 

Premium_Mode_Life: Has 5 different drop down choices.

Type_of_Application: Has 3 different drop down choices.

 

Once the user comples this screen and clicks on next, they are taken to a verfication screen where the information they selected in the prior screen is displayed via display text. What they selected for Premium_Mode_Life and Type_Of_Application is correctly being displayed on this screen.

 

Upon confirming the values are correct and clicking next, a record is then created. Two fields included in the new record are Premium_Mode_Life and Type_Of_Application. Neither of these fields are being added upon the record create.

 

I've triple checked and everything should be working correctly.

LloydSilverLloydSilver

I have to enter a stored value for each choice in order for this to work. I'd say it's definitely a bug.

DarrellDDarrellD

Are you assigning the selections to a variable and then using the variable to add/update the fields in the DB? If not, try that.

 

So you'd have an Assignment step after the user selection screen.

 

Darrell

RajaramRajaram
Make sure you have the "Stored Value" set for the choice. Take a look at this blog post http://blogs.developerforce.com/engineering/2012/03/working-with-choices-in-the-visual-workflow-cloud-flow-designer-oh-the-possibilities.html
to get more information on best practices