+ Start a Discussion
WEN JIEWEN JIE 

Problem when I using the Network Access function in Salesforce

Hi,

 

I have an app use the OAuth2.0 Username-Password Flow to get the access_token from Salesforce.

 

And I have already add my IP(static) in the Network Access, then I can get the access_token without security_token.

 

So, I add other team members IP in the Netword Access too. When they use my username and password to sent request to Salesforce, they can successful and can get the access_token without security_token. But when they use themselves credentail they can't sent request success, the Salesforce asking for security_token.

 

So, does anyone know why this problem happened?

 

Thanks!

NIKHIL_SFDCNIKHIL_SFDC

Hi,

 

Yes, you can avoid security token with your password but your IP should be static IP in the Netword Access or your specific IP should on Netword Access.

 


Did this answer your question? If not, let me know what didn't work, or if so, please  mark it solved, so that others may take help from this.

WEN JIEWEN JIE

Hi,

 

I have already add my IP in Network Access and I can get access_token from Salesforce without security_token. And I add our team members IP in Network Access too. So, if they access my application and use my Salesforce's username and password they can get access_token successfully don't need security_token.

But if they use themselves Salesforce's username and password, they can't get access_token from Salesforce. The Salesforce asking for security_token.

 

Thank you!

NIKHIL_SFDCNIKHIL_SFDC

Hi,

 

You can add IP of your team members in network access OR you can add IP address of team members on the profile.

 

Did this answer your question? If not, let me know what didn't work, or if so, please  mark it solved, so that others may take help from this.