+ Start a Discussion
SL TanSL Tan 

Re Need Advice on S-Control

Hi
I have been using the following S-Control header code to extract data for reports using button links successfully but now it just won't work. Could someone knowledgeable please kindly advise me what is wrong. I tried to change the script src to ajax 10.0, 11.0 and 12.0 but it just doesn't work. Any pointers will be highly appreciated.
Thanks in advance!

Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<link href="/dCSS/Theme2/default/common.css" type="text/css"
media="handheld,print,projection,screen,tty,tv" rel="stylesheet" >
<link href="/dCSS/Theme2/default/custom.css" type="text/css"
media="handheld,print,projection,screen,tty,tv" rel="stylesheet" >
<link href="/general/hide.css">
<style type="text/css" media="print">

@page port {size: portrait;}
@page land {size: landscape;}

.portrait {page: port;}

.landscape {page: land;}
.hide {
display: none;
}
</style>
<html>
<head>
<script src="/soap/ajax/9.0/connection.js"></script>
<script src="/js/dojo/0.4.1/dojo.js"></script>

 

SunilSunil

What error you are getting?

Thanks

SL TanSL Tan
Hi Sunil
Thanks for your message. I did not get any error message. Just a blank page.
I have logged in a case with Salesforce Support and waiting for a response
Best Regards
SL
SL TanSL Tan
Hi Sunil
Further to your earlier email, this is to let you know that we have solved the problem. Basically it is a script problem where we have an opening <script> tag that was not closed in our S-Controls. However the S-Controls and Custom Links were all working previously without the closing tag. Anyway, after removing this tag, all the affected S-Controls and Custom Links are now working fine.
I thought I will just keep you updated on this.
Thanks and Best Regards
SL