+ Start a Discussion
mahimahi 

not able to run apex explorer

hi all,
 
i got an error message saying : request failed with http status 407: proxy authentication required(ISA server requires authorization to fulfill the request. access to the web proxy filter is denied )
whenever i try to run apex explorer.
 
what changes should i make into tools-> options to make it run properly?
 
thanks,
mahi
Best Answer chosen by Admin (Salesforce Developers) 
GuyClairboisGuyClairbois

Hi all,

The below worked for my corporate proxy:

 

- Add the following block to the ApexExplorer8.0.exe.config file (usually located in C:\Program Files\salesforce.com\Apex Explorer 8.0):

 

  <system.net>
    <defaultProxy useDefaultCredentials="true"></defaultProxy>
  </system.net>

 

- Make sure you uncheck the "Tools->Use proxy" option in the Apex Explorer before logging in.

 

Rgrds,

Guy

All Answers

finkyfinky
Me too. I was using sforce explorer last night when it froze. then I could not log back in. I get an error message:  Login failed. The remote server returned an error.  (400) bad request.

I am running Windows XP Pro on a laptop and desktop and the same error occurs on both compuers
AkiTAkiT
Hi,

I' d really like to know also if somebody has managed to use Apex explorer with proxy?

I am able to enter the proxy addrees in the setup page but there is no space for proxy username and password, and program continues to give proxy authentication error (407).

-Aki
SuperfellSuperfell
Apex explorer does not support authenticating proxies, however .NET does, so you should be able to setup a .config file that specifies the proxy authentication info. you'll have to look on MSDN for the exact format, i don't have an example handy.
GuyClairboisGuyClairbois

Hi all,

The below worked for my corporate proxy:

 

- Add the following block to the ApexExplorer8.0.exe.config file (usually located in C:\Program Files\salesforce.com\Apex Explorer 8.0):

 

  <system.net>
    <defaultProxy useDefaultCredentials="true"></defaultProxy>
  </system.net>

 

- Make sure you uncheck the "Tools->Use proxy" option in the Apex Explorer before logging in.

 

Rgrds,

Guy

This was selected as the best answer
scasmflopscasmflop
Worked like a charm, thanks!
ColinKenworthy1ColinKenworthy1
Helped me out too, thanks.
fredkafredka

I am having the same problem.  I guess I do not have the necessary program to edit the ApexExplorer8.0.exe.config file ... guessing I need .net .... does anyone have any idea what exactly I need to modify the file ???

 

Thanks!!

scasmflopscasmflop
Just open it up with notepad.
fredkafredka

Brilliant!!!!! Thanks so much for helping me.... that worked!!!!!!

 

Fred

tmorrowxyztmorrowxyz

I'm trying to configure this apex tool in a Corporate environment that uses an authenticating proxy to access the internet. I've tried to add the suggested xml fragment to the default, out of the box ApexExplorer8.0.exe.config file without success. I've ensured that "use proxy" option is off (in fact it is greyed out). I keep getting the error "Login failed: The remote server returned an error: (407) Proxy Authentication Required." Can someone suggest what I may be doing wrong?

 

The only thing I can think of is that I have not placed the XML fragment in the right place in the config file or there is more to configuring it. I've tried placing it in various places, here's what I'm currently using:

 

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <configSections>
    <section name="SOQLSamplesSection"
      type="System.Configuration.NameValueSectionHandler" />
  </configSections>
  <appSettings>
    <add key="connstring" value="" />
  </appSettings>
  <SOQLSamplesSection>
    <add key="Simple SOQL" value="Select Id, Name, Industry From Account" />
    <add key="Account and Contacts" value ="Select a.AccountNumber, a.BillingCity, a.BillingCountry, a.BillingPostalCode, a.BillingState, a.BillingStreet, a.Id, a.Name, (Select Email, FirstName, Id, LastName From Contacts) from Account a" />
    <add key="Contact to Account Filtered by Account name" value="SELECT id, lastname, contact.account.name FROM contact, contact.account Where contact.account.Name = 'Global Media'" />
    <add key="Contact and CreatedBy user name" value="Select c.CreatedBy.FirstName, c.CreatedBy.LastName, c.Id, c.LastName from Contact c" />
    <add key="Aggregate - Count of Account" value="Select Count() From Account" />
    <add key="Account sorted by Name (ascending values)" value="Select Name from Account Order By Name" />
    <add key="Account sorted by LastModifiedDate (descending values)" value="Select Name from Account Order By LastModifiedDate Desc" />
    <add key="Using toLabel (translation workbench)" value="Select Company, toLabel(Status) from Lead " />
    <add key="Convert currency (multi-currency only)" value="Select convertCurrency(Amount), Name from Opportunity" />
  </SOQLSamplesSection>  
  <system.net>
    <defaultProxy useDefaultCredentials="true"></defaultProxy>
  </system.net>
</configuration>
 

GuyClairboisGuyClairbois

Hi,

it looks like the tag is at the correct location. Only 2 things I can think of:

- are you working on the right file? I recall there are 2 files delivered with the installation. You should edit the one in the path mentioned above. The other one belongs to the source code version of the program

- even if the proxy option is greyed out, it might have to specifically be unchecked. I think that if you change some settings in the options menu, the option of using the proxy will become available and you can unselect it.

 

Sorry for the somewhat vague answer but I don't have the package installed anymore so cannot verify my answers. I work with Eclipse now, which offers some more mature options (and full proxy support).

Rgrds,

Guy

arishi0arishi0

Great solution! Took a bit of exploring the settings and stuff but it worked just fine after I undid all I had changed while trying

Thanks!!!.

DeepakKapoor81DeepakKapoor81

Even after adding the specified xml I am not getting the same error message.and I am nowhere seeing the UseProxy checkbox. I have seen in tools->option there is no such checkbox.

 

Can you please let me know also what you have changed in setting?

DeepakKapoor81DeepakKapoor81

Hi Arishi,

 

I have added the XML tag but in tool-->Option I am not getting any checkbox to uncheck.

:smileysad:Please help me!!

DeepakKapoor81DeepakKapoor81

I have added the tag in correct file but I am nowhere getting the Use Proxy checkbox in tools->Option where will i uncheck that :-(

sabamonasabamona

Thanks Guy.. I struggled for hours, trying different workarounds unsuccessfully.. Your fix worked wiithin 5 minutes  :smileyhappy: