+ Start a Discussion
SQureshiSQureshi 

The REST API is not enabled for this Organization.

I'm facing the following error:

"The REST API is not enabled for this Organization.","errorCode":"API_DISABLED_FOR_ORG"

How to fix this issue? Or how to enable REST API for organisation?

Currently I'm using 30 days trial version of salesforce.com.

SuperfellSuperfell

30 day trial is profesional edition which doesn't include API access. If you specifcally want to try out the API sign up for a developer edition account.

SQureshiSQureshi

I have already signed up for developer account on below url:

https://events.developerforce.com/signup?d=70130000000EjHb

 

But trying rest API with this account also give the same error. Do I need to enable Rest API on developer account also. If yes, then how I can do that???

SQureshiSQureshi

When I use developer account it gives the following error:

error=redirect_uri_mismatch&error_description=redirect_uri%20must%20match%20configuration

 While I have set callback URL to : http://localhost:49944/SalesForceTest/Default.aspx

Developer account don't give Rest API (not enabled error) but the above error.

Sonam_SFDCSonam_SFDC

Hi,

 

This issue generally occurs when issue is with the callback URL that one is using.

The end user's browser will be redirected to this URI with the authorization code. This MUST match your application's configured callback URL.

 

Also If you are using the web-server flow, pls check the following parameters:

https://login.salesforce.com/services/oauth2/authorize?response_type=code&client_id=<your_client_id>&redirect_uri=<your_redirect_uri>

 

The following parameters are required (all must be URL encoded):

 

response_type -- Must be set to "code" to request an authorization code.

client_id -- Your application's client identifier (consumer key in Remote Access Detail).

redirect_uri -- The end user's browser will be redirected to this URI with the authorization code. This MUST match your application's configured callback URL.

Sophia Abraham 6Sophia Abraham 6
Hi All, 
I'm facing the same issue in the developer and professional trial editions as well.
@Sonam_SFDC, what do u mean by "redirect_uri -- The end user's browser will be redirected to this URI with the authorization code. This MUST match your application's configured callback URL"
As of now, my call back URL is the same as the initial login url: https://login.salesforce.com.
Is this incorrect?