+ Start a Discussion
fullvaluefullvalue 

Flex error 2032 Internet Explorer

Hi All,
    I have a flex app in a scontrol using the flex toolkit.  I get the error message below from IE.  It is not consinstant but only seems to happen in IE.  Also, it only seems to just started happening.  Help Please!

fault from operation: (mx.rpc::Fault)#0
  errorID = 0
  faultCode = "Server.Error.Request"
  faultDetail = "Error: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032"]. URL: https://na1.salesforce.com/services/Soap/u/10.0/111400D300000001JdX"
  faultString = "HTTP request error"
  message = "faultCode:Server.Error.Request faultString:'HTTP request error' faultDetail:'Error: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032"]. URL: https://na1.salesforce.com/services/Soap/u/10.0/111400D300000001JdX'"
  name = "Error"
  rootCause = (flash.events::IOErrorEvent)#1
    bubbles = false
    cancelable = false
    currentTarget = (flash.net::URLLoader)#2
      bytesLoaded = 0
      bytesTotal = 0
      data = (null)
      dataFormat = "text"
    eventPhase = 2
    target = (flash.net::URLLoader)#2
    text = "Error #2032"
    type = "ioError"
 

Ron HessRon Hess
What is your application trying to do when it encounters this error?
is it at the time of login or launch of the flex scontrol?
fullvaluefullvalue
It launches then logs in and queries information to populate the app.  From what I can tell by seeing the app in back of the error it looks like it has logged on and started to populate information.  Again, it is very inconsintant and it seems to only be happening in na1.  I can't seems to get it to reproduce in my dev instance na3.  But that might just be do to the inconsintancey.  
fullvaluefullvalue
This is still happening any help?
a_Ba_B

I have seen this hehaviour too. It seems that when I run more than one query simulteneously it gives me this problem. Mutiple asynchronous methods may be the root cause - queries here are asynchronous. But, I am not sure. Based on this hypothesis, I run the queries in the queue. I don't see that problem this way. 

 

If anyone knows more, please share.