+ Start a Discussion
rpr2rpr2 

Multistep Marketing customization guide can't be downloaded

Multistep Marketing isn't working for me and I'm 100% certain it's because I need to do some customization.  But what I need to do isn't clear without instructions, and I can't download the customization guide,  Can anyone else download it?

 

I'm using IE7 as my browser.

 

 

Best Answer chosen by Admin (Salesforce Developers) 
ReidCReidC

These are the only details I have -- sorry about the hardcoded ID.  I'm going through and removing those as I find them but haven't gotten to MSM yet.

 

The S-Control code you've included -- it looks to me like it's simply running a report and sending a multi-step campaign ID to it.  This is not an uncommon way to link to a report so I'm not surprised to see it.  When we replace these S-Controls, we typically replace them with a little bi of Visualforce and Apex that does the same thing.

 

Make sense?

 

From a next steps standpoint for you, I'd recommend looking at the reports and making sure you understand them and that they meet your needs.  Using the S-Controls might get there more directly, but you can absolutely go there through the Reports tab.If the report works the way you want, I'd go ahead use it and not worry about the button. 

 

HTH

 

 

All Answers

ReidCReidC

Looks like something was goofy with the doc.  I've corrected and you should be able to download it now.

 

https://sites.secure.force.com/appexchange/listingDetail?listingId=a0N300000016b2kEAA

rpr2rpr2

Thanks Reid for the quick response!  Now I was able to download the doc, but it didn't resolve the entire issue.  Looks like some instructions are missing from the doc - or something went wrong with my install.

 

I was getting an error message where the KPI report should display.

 

I'm not a Developer, but know just enough to get myself in trouble and sometimes enough to troubleshoot problems involving code.  In this case, I was able to find my way to the s-control that was trying to display the report and figured out that the reason for the error message was because I the ID for the report did not match anything in my org.  I was able to find the correct ID and substituted it into the s-control.  So, now it does display.  But, this wasn't in the documentation, and I'm not sure it is displaying like it should.  It's displaying the entire Salesforce page instead of just the report. 

 

KPI s-control display: https://cs3.salesforce.com/015Q000000092Ki

 

Maybe that is what the developer did intend, but I'm wondering if there are some other manual configurations I'm supposed to be doing, or if something went wrong with my install.  The s-control looks "weird" to me.  Stuff that's in the description looks like it really belongs as part of the body, but it's beyond my skill level to try to piece it together.

 

Custom S-Control Detail     


Review all error messages below to correct your data.
Label Marketing Schedule Analysis     
S-Control Name MarketingScheduleAnalysis 
    
Description <script language="JavaScript"> function redirect() { parent.frames.location.replace("../00O50000001HnMV?pv0={!SFL18_Multi_Step_Campaign__c.Id}") } redirect(); </script> 

00O50000001PgzH 
Type URL     
Encoding Unicode (UTF-8)     
HTML Body ../00OQ0000000KRGi?pv0={!SFL18_Multi_Step_Campaign__c.Id} 

 

 

 

ReidCReidC

These are the only details I have -- sorry about the hardcoded ID.  I'm going through and removing those as I find them but haven't gotten to MSM yet.

 

The S-Control code you've included -- it looks to me like it's simply running a report and sending a multi-step campaign ID to it.  This is not an uncommon way to link to a report so I'm not surprised to see it.  When we replace these S-Controls, we typically replace them with a little bi of Visualforce and Apex that does the same thing.

 

Make sense?

 

From a next steps standpoint for you, I'd recommend looking at the reports and making sure you understand them and that they meet your needs.  Using the S-Controls might get there more directly, but you can absolutely go there through the Reports tab.If the report works the way you want, I'd go ahead use it and not worry about the button. 

 

HTH

 

 

This was selected as the best answer