+ Start a Discussion
zachzach 

Minimum javascript version for AJAX Toolkit?

Hey, any of you know what minimum version of Javascript must be supported in the browser to use the AJAX Toolkit?

I've built a bunch of s-controls for web, but I'm trying to see if it will translate to BlackBerry & it seems like it won't... Blackberry says it supports Javascript 1.3 & parts of 1.4 & 1.5.
adamgadamg
The key piece required for AJAX is an XMLHTTPRequest object - I'm not sure (but somewhat doubt) that blackberry's browser supports that.

I think you'll need to go the route of writing a custom blackberry app if you want to go beyond its basic browser capabilities.