+ Start a Discussion
cirrocirro 

Winter '13 OAuth issues with iOS SDK?

I have a native project built on the iOS Salesforce Mobile SDK. We've been using for about 5 months now with no issues. 

 

I'm able to authenticate in our Winter '13 Sandbox, but am receiving an internal server error on callback. I've confirmed that this issue appeared when the sandbox was updated, and there were no code changes. 

 

Anyone aware of changes to the Rest API that might explain this? 

Best Answer chosen by Admin (Salesforce Developers) 
Kevin HawkinsKevin Hawkins

Oops, missed that you already upgraded.  It was an issue with older Mobile SDK clients, but ultimately resided in the service.  I believe old clients should be working now too.

All Answers

Tom GersicTom Gersic

What is the call that is causing the internal server error?

cirrocirro

I'm a little unclear on what the debugging is telling me. It looks like 

 

SFOAuthCoordinator:webView:shouldStartLoadWithRequest: (navType=1): host=cs11.salesforce.com : path=/secur/frontdoor.jsp

 

did not load a response. In any case, updating to the lastest version of the SDK resolved all issues, so I'm assuming it is related to 

 

https://github.com/forcedotcom/SalesforceMobileSDK-iOS/issues/117

Kevin HawkinsKevin Hawkins

I believe this is fixed now.  Can you try again and see if you still experience the same issues?

 

Thanks,

Kevin

 

Kevin HawkinsKevin Hawkins

Oops, missed that you already upgraded.  It was an issue with older Mobile SDK clients, but ultimately resided in the service.  I believe old clients should be working now too.

This was selected as the best answer