+ Start a Discussion
justdevjustdev 

Google Maps

Hi,

I followed the instructions and setup Google Maps custom tab.

When I access this custom tab, I can see the Google map, but none of the accounts/leads/contacts are mapped.

All my search conditions, returns with "Search Complete, 0 records mapped.".

In some search conditions, I got popup messages saying that "50 of 211 records processed. Would you like to continue mapping more records?" etc, but at the end of it, nothing gets mapped.

I am checking this with Developer Edition. Is that a reason why this is not working?

Any suggestions?

Thanks,
Ayyappa
DevAngelDevAngel
This is likely due to cross domain scripting security restrictions. Edit the scontrol and find the line that is var diagnostics = "off" and change it to on. You should see a button that will display a "log" div that should indicate why the processed records could not be mapped.
cissecisse
Hey JustDev

Did you ever fix this GMaps issue? I'm having the same problem, I also can't figure out how GMaps is relating to the Lat and Lon fields that were added to Leads, Accounts and Contacts.

Any help would be much appreciated.

Thanks

Djib
justdevjustdev
Please refer http://salesforce.breezecentral.com/buildgmaps/

There is a internet explorer security setting (Enable Access data sources across domains in the Custom level settings). There is a slide in the above presentation on this.
cissecisse
Thanks for the response, I set this feature up based on this presentation. I've changed the security setting - still no luck I'm afraid.
justdevjustdev
One thing that happened to me is, when we select a search criteria the first time, it updates "lat" and "lon" custom fields in the account/lead record with the latitude and longitude which will be used by the mapping. So i saw the pins appearing when i did a blind search for all accounts.
AlibabaAlibaba

I am getting the same issue. Most search conditions return 0 records, even though they clearly match the search criteria. Looking at the diagnostics only shows me SQL statements that look perfectly valid yet return 0 records. When I do search some criteria that do return records (usually something that returns everything), they still don't map. The error code is "Skipped geocoding, probably more than one result.
Using google scraping...". Any ideas?

Any help would be appreciated!

Ron WRon W

Also no luck in getting this to work. and don't see  a line     var diagnostics = "off"

help appreciated

cringholzcringholz

The presentation (slide 4) says to get the code from the link an the page where we selected the Breeze presentation.  I linked directly to the presentation and can not find the code.  Does any one have this?