+ Start a Discussion
Blue85Blue85 

Excel Connector stopped working for some reason?? Error: Macro may not be available...

I had difficulty installing and it worked for an hour or so.  Now I'm getting one of two errors:

 

When I start the Connector from the menu on the Add-Ins tab:

Cannot run the macro ''C:\Documents and Settings\sglickman\Desktop\sforce_connect_for_pe.xla'!sfDescribeAndQuery'. The macro may not be available in this workbook or all macros may be disabled.

 

Note that I do have all macros enabled (in the Excel 2007 Trust Center)

 

If I were to open Excel by clicking on the sforce_connect_for_pe.xla file on my desktop (No other Excel sessions were running:

A document with the name 'sforce_connect_for_pe.xla' is already open. You cannot open two documents with the same name, even if the documents are in different folders.
To open the second document, either close the document that's currently open, or rename one of the documents.

 

 

I would really appreciate help from anybody out there that may have experienced the same problems.  I'm using Professional Edition with Excel Office 2007.

 

Thanks!!

Steve

Best Answer chosen by Admin (Salesforce Developers) 
Cheriah200Cheriah200

 I think you're having the same problem that i had when I first installed this program.  It needs to be installed in a certain way,  otherwise you get errors when running it.  When it is installed and working correectly though it is a fantastic tool, so stick with it!

 

I had to uninstall/delete the program and then re-install it to get it working.  Once you've uninstalled it, follow the details below to get it working properly. 

 

Note:  When uninstalling the program, make sure you also go into excel and delete it from the toolbar before trying to reinstall it and run it again as it won't work.  Go to Tools, Customise, select the Toolbars tab, scroll down to highlight sforce Connector and click delete. 

 

Now reinstall following these instructions:-

 

 

  • DO NOT click on the .xla file, as doing so will cause headaches later (trust me).

 

  • Place the .xla file in the following directory:  C:\Documents and Settings\<User>\Application Data\Microsoft\AddIns.

 

Launch Excel, click Tools --> Add-ins and select the “SForce_Connect...” option and hit OK.  If you don't see this option, you didn't follow the above bullet points correctly correctly, or you need to Browse to the directory where you stored the .xla file.  You should see a message about Macros (you need to enable them), and a Toolbar with “SForce Connect...” will pop up.  You are on your way!

 

In SF go to Setup-->My Personal Information-->Reset My Securtiy Token and reset your security token.  An email will be sent with this token...you will need it to login in via the Connector.

 

Now you are ready to start importing.

 

These notes worked for me!

 

Good luck!

All Answers

Cheriah200Cheriah200

 I think you're having the same problem that i had when I first installed this program.  It needs to be installed in a certain way,  otherwise you get errors when running it.  When it is installed and working correectly though it is a fantastic tool, so stick with it!

 

I had to uninstall/delete the program and then re-install it to get it working.  Once you've uninstalled it, follow the details below to get it working properly. 

 

Note:  When uninstalling the program, make sure you also go into excel and delete it from the toolbar before trying to reinstall it and run it again as it won't work.  Go to Tools, Customise, select the Toolbars tab, scroll down to highlight sforce Connector and click delete. 

 

Now reinstall following these instructions:-

 

 

  • DO NOT click on the .xla file, as doing so will cause headaches later (trust me).

 

  • Place the .xla file in the following directory:  C:\Documents and Settings\<User>\Application Data\Microsoft\AddIns.

 

Launch Excel, click Tools --> Add-ins and select the “SForce_Connect...” option and hit OK.  If you don't see this option, you didn't follow the above bullet points correctly correctly, or you need to Browse to the directory where you stored the .xla file.  You should see a message about Macros (you need to enable them), and a Toolbar with “SForce Connect...” will pop up.  You are on your way!

 

In SF go to Setup-->My Personal Information-->Reset My Securtiy Token and reset your security token.  An email will be sent with this token...you will need it to login in via the Connector.

 

Now you are ready to start importing.

 

These notes worked for me!

 

Good luck!

This was selected as the best answer
Blue85Blue85

Thank you so much, Cheriah!!

 

 

At first I couldn't get the Add-In removed from my toolbar even though I deselected it from the Add-In list.  Since I'm using Excel 2007 (ugh!), there is no Tools menu; everything is in a different place from the old Excel.

 

I did get it working, though.  And, hopefully, it will stay working!  It's a great tool, especially since I had to delete about 23,000 junk records and can't mass delete any other way since I'm using the Professional edition.

 

Again, thanks for your help!  I really appreciate the time you took to respond.  Have a great day!

 

Steve

KissaKissa

I am having this same problem only I get

'sforce_connect_for_pe1.htm' could not be found. Check the spelling of the file name, and verify that the files location is correct.

I have removed the add-on and deleted it from the location but can't get to leave from the add-ins toolbar.

 

I have Excel 2007 and and find anywhere to do it.

 

Help!

KissaKissa
I haven't used the prgram is several months, but now I really need to and I am still having this problem. Anyone got any answers??