+ Start a Discussion
wcwill978wcwill978 

Unable to refresh reports!!!!

As of a couple of days ago some users began seeing the following error when attempting to refresh reports in Excel:

 

Unable to open https://na6-api.salesforce.com/&export=1xf=xls&enc=UTF-8. The Internet site reports that the item you requested could not be found. (HTTP/1.0 404)

 

They also mentioned that the spinning globe does not appear like it usually does. SFDC support reffred me to come here and post thsi isue to see if there's something going on with the tool.

 

Please help thank you!

Rhonda RossRhonda Ross

I'm assuming that you are referring to Connect for Office, instead of Excel Connector.  If that is the case, perhaps the location of the reports were changed or security to the folder changed.  Have the users with the issue tried to run the reports used in Excel manually to see whether they access the reports from the UI?

wcwill978wcwill978

yes i was refering to the Connect for Office. Salesforce acknowledged that this is a bug with Spring '12. What happened was that we recently changed all our folders to permission of Accesible by all users, Except Portas Users" If you use this default permission then it breaks the connector, for some reason its running as a portal users and they dont know why or when they'll have a fix.

 

As soon as I changed it back to "Accessible by all users, Including Portal Users" it works. A workaround is to set it to "Only accessible by the following Users" and then add all internal roles or build a public group with only internal users and share the folder that way.

acousticacoustic

Ok.. I get the same error, but no permissions or settings have been changed. One day I am able to refresh all the reports, the next day I have this error. 

I looked at the data connections and the Salesforce Report IDs magically disappeared from the connection URLs. 

 

Any Suggestions?