+ Start a Discussion
Roger WickiRoger Wicki 

Special Characters Web to Lead

Dear Community

We're almost done with our Web to Lead implementation. Now we just found out that whenever one enters carriage return characters in a text area field on the website, which is going to be written to a text area field in salesforce, there is no lead created after submitting.

Furthermore, Salesforce seems not to be capable to convert php encodings back to the original character. As I'm having a trigger on lead anyway for that reason, I can adapt this, but not supporting carriage returns is a pretty bad problem. I am not even getting a debug log during this test.

Any hints on that?
Best Answer chosen by Roger Wicki
Roger WickiRoger Wicki
We tried this and it led to no solution. However, our webadmin sent the data in another way and it worked out. The custom fields seemed to be the problem there...
Anyway, it's working now.

All Answers

AmitAmit (Salesforce Developers) 
Hi, Kindly go through the below link that will explain the usage of escape characters in salesforce.

http://www.salesforce.com/us/developer/docs/soql_sosl/Content/sforce_api_calls_soql_select_quotedstringescapes.htm                                                                                 

Hope this answers your query.
Roger WickiRoger Wicki
We tried this and it led to no solution. However, our webadmin sent the data in another way and it worked out. The custom fields seemed to be the problem there...
Anyway, it's working now.
This was selected as the best answer
AmitAmit (Salesforce Developers) 
Hello Roger,

Thanks for the information.

I would request you, if you could share some more information about the resolution so that more people could be helped.

-Thanks