+ Start a Discussion
praveen murugesanpraveen murugesan 

Google visualizations is not displaying in Internet Explorer.

Hi all,

I am using google visualisation API to display ORG chart. It is working fine in chrome,Safari and Mozilla but not in IE11. In IE it is working fine for few employees. But if I tried with entire organizaiton employees means it is not showing.

The problem is in only production not in sandbox

Any fixes for this would help.

Thanks in advance.
Ashish_SFDCAshish_SFDC
Hi Praveen, 


This seems to be an issue with the Salesforce Browser Settings, 

See the links below,

Configuring Internet Explorer

http://help.salesforce.com/HTViewHelpDoc?id=getstart_browser_ie.htm&language=en_US

Supported Browsers

https://help.salesforce.com/apex/HTViewHelpDoc?id=getstart_browser_overview.htm&language=en


Regards,
Ashish
praveen murugesanpraveen murugesan
Hi Ashish,

I have checked with your link and changed the setting as per that eventhough the it is not displaying an chart.

Thanks
praveen murugesanpraveen murugesan
Hi All,

I have found the reason for this. But trying to get the solution.

By using Inspect Element in both the browser (IE and Chrome) I found few lines of code not getting excuted in IE. Those line only used to display the chart.

Code in IE:

<div class="chartFrame" id="chart_div"> </div> // Inside the div there is not code.

Code in Chrome:

<div class="chartFrame" id="chart_div"> 
<table class="google-visualization-orgchart-table" dir="ltr" cellpadding="0" cellspacing="0" align="center"><tbody><tr><td class="google-visualization-orgchart-space-medium"></td><td class="google-visualization-orgchart-space-medium"></td><td class="google-visualization-orgchart-space-medium"></td><td class="google-visualization-orgchart-space-medium"></td><td .......................................(this code is 155 pages in word)

</div>

Thanks.