+ Start a Discussion
Ken KoellnerKen Koellner 

Salesforce1 version on Android, I get Chatter 3.4.2 when I downloaded from the Play Store.

I went to the Android Play Store on my Android phone and found the Salesforce1 App.  It shows a date of 3/17/2014 and includes comments --

What’s new in 5.1.1:
• Bug fixes and improvements
What’s new in 5.2:
• Custom Branding
• Bug fixes and improvements

But when I downloaded it , I get the Chatter icon, not the SF1 icon.  And when I run it and check the version it says it is "About Chatter Version 3.4.2 Build number 8".

Am I not getting the latest version?  Anyone know why?

For one thing, I'm only getting "Feed" and RECENT, not the other tabs I have configured including some custom pages under APPS.  All these work fine on iPad when pointing to the same org.
SuperfellSuperfell
What version of Android are you using?
Ken KoellnerKen Koellner
Android version 4.1.2.
Ken KoellnerKen Koellner
I noticed the SF1 page says -- Android OS 4.2

So I guess my phone isn't new enough.

I don't know if my phone can be upgraded or if SF will ever support 4.1.
Mark DrummondMark Drummond
I have the same version Android and am having the same problem. I checked to see if there was an update available but there isn't. Not sure what to do now.
Ken KoellnerKen Koellner
I think it's SOL unless Samsung/ATT decide to update my phone to 4.2 or SF decides that it should support 4.1.2.  With 4.1.2 phone still on the market and SF1 being almost a year old now, you think SF would have built it without requiring 4.2.
HarishGoudd BuuraHarishGoudd Buura
Hi Ken,
I had same issue with android. I got solution.

The latest version of Salesforce1 requires devices with Android OS 4.2 (Jelly Bean) or later. Devices with Android OS 4.1 or earlier will receive Chatter Mobile 3.4  with logi Chatter only.