+ Start a Discussion
JessBJessB 

VF Pages created 1/2014 not displaying images or table content anymore

Hi,

I created a couple of VF pages in January, and one is no longer rendering an image that I have as <apex:image value="mylinkhere"  inside the code, that refers to an "Externally Available Image" in the Documents object. It's rendering as some kind of broken image (see the grey box with a tree), not the one I have uploaded in SF. Note, I checked the image source URL and it works; it's not a broken link.

The same page is also not loading any data/text in my tables beyond the initial header (everything below the YEAR(TODAY()) formula piece.

Both VF page versions are 30.0.

Please advice on what may have changed in Visualforce since January, and how I need to  update my code. A snippet is provided below. 
<apex:page standardController="Marketing_Action_Plan__c" renderAs="pdf" showheader="false" applyHtmlTag="false">
<apex:pageblock >
<head>
<title>Marketing Action Plan</title>
<apex:stylesheet value="/sCSS/20.0/sprites/1290470434000/Theme3/default/sf/common.css"/> 
<apex:stylesheet value="/sCSS/20.0/sprites/1290470434000/Theme3/default/sf/extended.css"/>
<style type="text/css">
td { font-family: helvetica; }
@page{
            margin:0.10in;
        }
</style>
</head>

<body>
<table style="width:600px" border="0" cellpadding="0" cellspacing="0">
    <tr>
    <td rowspan="4"><apex:image id="UltherapySeeTheBeautyofSound2" value="https://c.cs1.content.force.com/servlet/servlet.ImageServer?id=015S0000000Td3I&oid=00DS0000001Dcun&lastMod=1386700403000" width="159" height="40"/></td>
      </tr>
      <tr>
      <td style="font-size:18px" align="left" valign="left" bgcolor="white"><b>Marketing Action Plan </b></td>
    </tr>
    <tr>
     <td style="font-size:14px" align="left" valign="middle" bgcolor="white"><b>{!Marketing_Action_Plan__c.Account__r.name}</b></td>
    </tr>
    <tr>
      <td style="font-size:9px" align="left" valign="middle" bgcolor="white"><b>{!MONTH(TODAY())}/{!DAY(TODAY())}/{!YEAR(TODAY())}</b></td>
    </tr>
     </table>
<br/>
<br/>
<br/>
<table style="width:1500px" border="0" cellpadding="0" cellspacing="0">
<colgroup>
<col width="10"/>
<col width="1490"/>
</colgroup>
<tr>
<td style="font-size:12px" colspan="2"><b>{!if(Marketing_Action_Plan__c.Cust_Assmnt_Database__c="0-2500", "LOW", "")}</b></td></tr>
<tr>
<td style="font-size:11px" colspan="2"><b>{!if(Marketing_Action_Plan__c.Cust_Assmnt_Database__c="0-2500", "Tactics:", "")}</b></td></tr>
<tr>
<td style="font-size:6px">&nbsp;</td></tr>
<tr>
<td style="font-size:9px" colspan="2"><b>{!if(Marketing_Action_Plan__c.Cust_Assmnt_Database__c="0-2500", "Online Search", "")}</b></td></tr>
<tr>
<td style="font-size:7px">{!if(Marketing_Action_Plan__c.Cust_Assmnt_Database__c="0-2500", "", "")}</td>
<td style="font-size:7px">{!if(Marketing_Action_Plan__c.Cust_Assmnt_Database__c="0-2500", "How to Use Google AdWords", "")}</td>
</tr>
<tr>
<td style="font-size:7px">{!if(Marketing_Action_Plan__c.Cust_Assmnt_Database__c="0-2500", "", "")}</td>
<td style="font-size:7px">{!if(Marketing_Action_Plan__c.Cust_Assmnt_Database__c="0-2500", " • Optimize website", "")}</td>
</tr>
</table>
</body>
</apex:pageBlock>
</apex:page>

sam sammsam samm
Why dont you try saving the image in the static resource and calling it on page instead of hardcoding the url.

Add a static resource : Pictures/Myimage.jpg

<apex:image  url="{!URLFOR($Resource.Pictures, '/Myimage.jpg')}"  />

Hope this helps.