+ Start a Discussion
Nikhil RupadaNikhil Rupada 

Canvas app is not working in IE

I am having web application developed in .net,which is integrated with SF using canvas app, which is not working in IE where as it is working in Chrome and FF, I also looked into the below forum which suggest to not to use frames,
https://developer.salesforce.com/forums/ForumsMain?id=906F00000009Zaj

so that I tried loading a simple page which contains a single text line , but still it was not working in IE. 

I tried all other settings as suggested in SalesForce help documents as well but still not working. For your refference when I opended developed option, it was throwing below error.

SCRIPT87: Invalid argument.

CanvasRendering.js, line 39 character 185

 

Please help asap

Best Answer chosen by Nikhil Rupada
jhurstjhurst

Nikhil,
 

We were seeing this issue when using true or false as values for the scrolling attribute in a canvas app VF component:

 

<apex:page>
     <apex:canvasApp developerName="MyApp" scrolling="false" />
</apex:page>
The valid values for scrolling are "yes", "no", and "auto".  We have updated the Summer '14 documentation to reflect this and we have changed our validation to be ore lenient.

In the meantime, can you verify that setting the value to yes/no/auto fixes the issue?  If it does not, can you log a support ticket with login access to your org and steps to reproduce?  Then respond with the case number and I can take a look.

Hope this helps.
Jay

All Answers

Nikhil RupadaNikhil Rupada
As an update its having issue in scrolling related things, particularly in this statement,
d.scrolling=b.scrolling (In IE browser)

Also in other browsers its showing "Failed to load resource: net::ERR_INSECURE_RESPONSE" error.
but as other browsers handles error and not breaking whole page load its working in other browsers.

I hope It may help you to point to particular issue.

I need to resolve this issue and need to have my app working for IE users as well, so please do the needful asap.
jhurstjhurst

Nikhil,
 

We were seeing this issue when using true or false as values for the scrolling attribute in a canvas app VF component:

 

<apex:page>
     <apex:canvasApp developerName="MyApp" scrolling="false" />
</apex:page>
The valid values for scrolling are "yes", "no", and "auto".  We have updated the Summer '14 documentation to reflect this and we have changed our validation to be ore lenient.

In the meantime, can you verify that setting the value to yes/no/auto fixes the issue?  If it does not, can you log a support ticket with login access to your org and steps to reproduce?  Then respond with the case number and I can take a look.

Hope this helps.
Jay
This was selected as the best answer
Nikhil RupadaNikhil Rupada
Hey Jay,

Thanks a ton.

With Regards,
Nikhil