+ Start a Discussion
turbo2ohturbo2oh 

linker error in xcode on sample hybrid projects build

I've tried importing 2 of the sample projects into xcode generated via 'forceios create samples'. They both have the same 5 errors when I try to build the project.

Here's an example of one: 
Apple Mach-O Linker Error "_OBJC_CLASS_$_SFKeyStoreManager", referenced from:

objc-class-ref in libSalesforceOAuth.a(SFOAuthCredentials.o)

It then has several very similiar ones for SFPasscodeManager, SFSDKCryptoUtils, _kSFPassCodeProviderPBKDF2, and the last is Linker command failed with excit code 1.

Any suggestions on how to fix this? I've tried removing and re-adding the www folder as suggested in a read.me file.
turbo2ohturbo2oh
I've also noticed theres are 3 red files under SalesforceSDKCore, I'm guessing its looking for these but not finding them? SFAccountManager.h, SFPasscodeManager.h, and SFPasscodeProviderManager.h. I don't see these in the actual directories outside of xcode.
hayzehayze
+1.  I am also having this exact problem.  I'm sure it's related to the missing header files.
Hari hara suthanHari hara suthan
I am also faced the same issue. Its because build version miss matching. try to create new hybrid app and replace index.html from accountEditor sample to your new app. I tried myself and it works fine.

Darren JiangDarren Jiang
Have you resolve this problem now? Cause I am also face the same one.If you  fix it, could you please help me. Thank You!