+ Start a Discussion
BugudeBugude 

Callout Timeout Issue

We understand that the callout timeout is maximum of 120000 milliseconds (120 sec) and the default timeout is of 10 sec.
We have set the timeout_x variable to 120000 but still the timeout is occuring at 60 sec and the error message is shown as below in the debug logs.

IO Exception: External server did not return any content

does this mean that the response has been returned but without any content or are we having timeout at salesforce end.

Please help!.
Sumitkumar_ShingaviSumitkumar_Shingavi
It sounds like server is not sending response itself! Can you setup a System.debug on response string and see in logs if you get anything in there. I think Salesforce is hoppeing/waiting for response but doesn't listen anything for 120secs.

PS: if this answers your question then hit Like and mark it as solution
BugudeBugude
The setup.debug was not returning any details but we figured out that the ETL was the main cause of the Issue.

There were two differnt timeouts set for ETL tool, one at ESB layer and another one at Workflow layer. As any requests have to pass through ESB (either pass through or workflow), the timer starts at ESB. The ESB layer timeout was set at 60 sec where as workflow timeout was set at 120 which was resulting in this odd behaviour.

The issue is not exactly with timout occuring at salesforce, we are receiving the response from ESB layer (timeout response) which was a blank message that was causing this issue.