+ Start a Discussion
hy.lim1.3897974166558203E12hy.lim1.3897974166558203E12 

My 'Reply' & 'Reply to All' button missing from email message feed when using custom emailpublisher

 Hi i have a very simple email publisher to replace the original one :->

<apex:page standardController="Case" >
  <apex:emailPublisher entityId="{!case.id}" 
      fromVisibility="selectable"
      subjectVisibility="readOnly" 
      toVisibility="readOnly"
      fromAddresses="support@abc.com}"
      emailBody=""/>
      
</apex:page>
So i remove the standard 'Answer Customer' action and add in my custom emailpublisher in. Now all my email message record feed doesn't have the 'Reply' & 'Reply to All' button. What have i missed out? Basically what I want to achieve is I want the sender to default as our support email instead of user's personal email.

With Answer Customer Action
User-added image


Without Answer Customer action (replaced with my custom email publisher)
User-added image

Sonam_SFDCSonam_SFDC
Did some research around this and looks like the reply and reply All button are available only whe using the standard actions and not with the custom email publisher.

Following are the only workarounds:
- use the standard action so the buttons will be present.
- access the Email Message to get the option of 'Reply' and 'Reply All'. 


hy.lim1.3897974166558203E12hy.lim1.3897974166558203E12
Hi Sonam,

If i access to the Email Message then I wont be able to use the case feed email editor already. No point for me to enable case feed to my users
Kevin StrangeKevin Strange
Holy moly - did they ever screw this one up. The whole case feed, custom publisher's, standard publisher, Reply, Reply All, 
 none of these work. Warning about Service Cloud Winter 15 - you simply cannot interact with customers via email as none of these tools 
 work. Being able to email customers, with a preselected template - should be a piece of cake - I've spent 6 months working with these new tools and there are simply no easy or straightforward workarounds available. Huge setback for Salesforce here. 
Ajay ChakradharAjay Chakradhar
Hi All

When "Reply" and "Reply All" Actions are not showing in Email List in Pagelayout.Try to check the settings as follows

Setup | Email Administration | Deliverability

Under " Deliverablity " Check " Access to Send Email "  Access Level choosen to " All Emails " are not,If not change it to " All Emails " and Save it.
Luke Higgins - RFLuke Higgins - RF
Ajay nailed it.
David ForelDavid Forel
Ajay: Thank you! Thank you! Thank you!
I found that, even though "All Emails" was set, I used Save, logged out, and found the buttons had been restored when I came back.