+ Start a Discussion
Andrei KuznetsovAndrei Kuznetsov 

New button doesn't work on Web tab for standard object.

Hi All,

I have web tab that points to Opportunities standard object. The URL is http:///006/o?isdtp=vw, and I expected this to mimic Opportunities standard tab. And the page that opens up looks pretty much the same. But, neither New nor New Opportunity buttons don't work. Nothing happens when I click on them. Does anyone know why? Note: creating VF tab that points to Opportunities object works fine with regard to the same buttons. Thank you!
Best Answer chosen by Andrei Kuznetsov
Sonam_SFDCSonam_SFDC
At the time of creating the Web tab, you get an option to either show the left pane or show the complete page - Go back to th Web page - Edit it and while on the wizard, it will gve you the option to choose the frame with side panel - choose that one and it should show you the left panel on the web page

Pls mark as the best answer if this solves your issue so others can benefit from it.


All Answers

Sonam_SFDCSonam_SFDC
Change the link to https://<your ORG instance>.salesforce.com/006?isdtp=mn and the new buttons should work.
Andrei KuznetsovAndrei Kuznetsov
Thank  you. This seems to do the trick. Do you mind if I also ask you why the left pane of SF screen doesn't show up in both cases?
Sonam_SFDCSonam_SFDC
At the time of creating the Web tab, you get an option to either show the left pane or show the complete page - Go back to th Web page - Edit it and while on the wizard, it will gve you the option to choose the frame with side panel - choose that one and it should show you the left panel on the web page

Pls mark as the best answer if this solves your issue so others can benefit from it.


This was selected as the best answer