+ Start a Discussion
NewportNewport 

Custom Logo on Salesforce Site

I'm probably missing something basic...

I cannot get my company's logo to appear on the public facing Salesforce Site that I'm creating with a custom Visualforce page.

It works in the sandbox, but not in production.

I've set the Sites' "Public Access Settings" (my Site's public unauthenticated Profile) to see my custom App by default.

I've uploaded and put the logo into my My Personal Documents folder, and from there, into that App.

I've set the logo to be an Externally Available Image, and it's only a 4K gif.

I've even double-checked that the layout shows a header component (that exists) which displays my logo, although I'm not sure any of that is used when displaying my Visualforce page in the site.

I've been through all the permissions with a fine toothed comb.

Any suggestions as to where to look would be appreciated, even long shots.

Thanks in advance.
sunny522sunny522
Hi Newport,
         It may be due to folder permissions.can u place the logo into another public folder where all users can access that logo.
let me know if it helped.
NewportNewport
Thanks for the effort Sunny.

But I'm sorry to say that that didn't work.

I uploaded the logo to the Shared Documents folder, and into the custom app that my Site Guest User is supposed to see by default.

I then tried the same thing with every other image in that folder, and then every other image in any folder in production.

I then verified that my Site's Guest User sees that custom App, by going to the site, clicking "Public Access Settings" and verifying that the "visible" and "default" checkboxes next to my custom App were checked.

I really don't know what else to do.
NewportNewport
...Amazingly, I had a co-worker tinker with this. He solved the problem by simply going to the Site's Guest User (un-authenticated user) Profile and changing the Documents Tab from "Tab Hidden" to "Default On".

When we refreshed the Site, the logo from my custom App appeared! No Tab appeared. Even more amazingly, I then went back into the Guest User Profile (by pushing the "Public Access Settings" button on the Site's setup page) and switched the Documents Tab back to "Tab Hidden", and when I refreshed the Site it continued to display my custom logo.

This seems like a bug in Salesforce.

I know many will think that I changed something else, but I did not.