+ Start a Discussion
Mitch McConnellMitch McConnell 

Eclipse Schema explorer not displaying relationship values

I am running the Force.com IDE in Eclipse (Kepler).

When I try and create a SOQL query, it is not resolving the relationships correctly.

For example, when I run this simple query:

      select Id, Account.Name from Opportunity

It returns rows like this

Id                                                      Name                                              Account
003i000000IugISAAZ                   Fred Roberts                                 Account
003i000000Iug04AAJ                  Bob Smith                                      Account

In other words, it does not show the Account name, but just the word "Account".

When I run this in the developer console, it is correct.

Is there some type of misconfiguration in my IDE setup?

Thanks,

Mitch

Best Answer chosen by Mitch McConnell
Grazitti TeamGrazitti Team
Hi Mitch,

There is no misconfiguration in your IDE setup. Account is showing because it a object when you click on that account then a popup will appear showing the name of the account. That popup will contain the fields of the account which you get in the query.

Please mark it best if it helps you.

Regards,
Grazitti Team 
www.grazitti.com

All Answers

Grazitti TeamGrazitti Team
Hi Mitch,

There is no misconfiguration in your IDE setup. Account is showing because it a object when you click on that account then a popup will appear showing the name of the account. That popup will contain the fields of the account which you get in the query.

Please mark it best if it helps you.

Regards,
Grazitti Team 
www.grazitti.com
This was selected as the best answer
Mitch McConnellMitch McConnell

Thanks... I feel kind of stupid, but that is not the UI behavior I would have expected... why not just print the field

I asked for?