+ Start a Discussion
UdhayaUdhaya 

Error: objects/Account.object(Account):Property 'compactLayoutAssignment' not valid in version 28.0

Build script suddenly started throwing "Error: objects/Account.object(Account):Property 'compactLayoutAssignment' not valid in version 28.0". From Salesforce documentation i can understand that compactLayoutAssignment is supported in version 29.0 or later. I know how to change the version for apex class but this is releted to object. How can we change the version for Objects in Salesforce? 
Best Answer chosen by Udhaya
UdhayaUdhaya
Sandbox refresh resolved the problem.

All Answers

ShashankShashank (Salesforce Developers) 
Hi,

Objects do not have versions. The API version number 28.0 that you are seeing is of the Apex class itself, and changing the version of the apex class should do the trick for you.

If this answers your question, please mark this as the Best Answer for this post, so that others can benefit from this post.

Thanks,
Shashank
UdhayaUdhaya
Hi Shashank,

Thank you very much for quick response.

Again, I am sorry I am confused here. Error points at Account.object but you are asking to change the version of the Apex class.

Which apex class i have to change? Should i change the version of all apex classes?

Thanks,
Udhaya
UdhayaUdhaya
Sandbox refresh resolved the problem.
This was selected as the best answer