+ Start a Discussion
SF Buzz VutukuriSF Buzz Vutukuri 

No clean data columns available for custom fields

User-added image

Please help me in fixing this error
Best Answer chosen by SF Buzz Vutukuri
Megan PietruszkaMegan Pietruszka
https://help.salesforce.com/articleView?id=000265626&type=1 is the only Knowledge Article live that I can find on this; just says the same thing, open a case if you've fully erased the deleted fields and are still getting the error.

All Answers

ShashankShashank (Salesforce Developers) 
This article explains how to fix this issue: https://help.salesforce.com/apex/HTViewSolution?urlname=Package-install-fails-with-the-error-No-clean-data-columns-available-for-custom-fields&language=en_US
SF Buzz VutukuriSF Buzz Vutukuri
NO, It's not working, and we got this error in sanbox organization
ShashankShashank (Salesforce Developers) 
Yes, this error is specific to sandbox orgs. The workaround mentioned in the article should resolve the issue.
SF Buzz VutukuriSF Buzz Vutukuri
Hi Shashank,
Thanks for ur Response.

I got error in PriceBookEntry object in our SandBox(Enterprice Edition).But we unable to create new custom field in Same Object.

we are getting following error

" "No clean data columns available for custom fields.""  
ShashankShashank (Salesforce Developers) 
Can you try accessing this page in your sandbox from which you can create a custom field and delete it folowed by hard deletion? replace instance with your sandbox instance: https://instance.salesforce.com/p/setup/layout/LayoutFieldList?type=PricebookEntry
SF Buzz VutukuriSF Buzz Vutukuri
Yes, We did the same thing still we are facing the same error ............
ShashankShashank (Salesforce Developers) 
I would recommend you to raise a case with salesforce support to report this issue so that they can investigate further.
Ken Koellner 1Ken Koellner 1
Search for this issue and see that the URL above (https://help.salesforce.com/apex/HTViewSolution?urlname=Package-install-fails-with-the-error-No-clean-data-columns-available-for-custom-fields&language=en_US) is cited as the solution.  And of course SF either moved or deleted the article so now that URL is a 404.  Ughhhhhhh.
Megan PietruszkaMegan Pietruszka
https://help.salesforce.com/articleView?id=000265626&type=1 is the only Knowledge Article live that I can find on this; just says the same thing, open a case if you've fully erased the deleted fields and are still getting the error.
This was selected as the best answer
SF Buzz VutukuriSF Buzz Vutukuri

I am sorry guys, it was raised long ago when I was in other company, I remember that we have raised a case to Salesforce they did the Job.

Thanks for your responses.