+ Start a Discussion
hyjhyj 

When using TLS1.0 instead of SSL3.0, what should I change in my API integration for Authorization?

Hi all,

In my API integraion, I'm using username and password to get a session id and getting data by Http Web Request with this session.
Recently, I'm told that Salesforce would support TLS 1.0 and disable SSL 3.0.
I've no idea what should I change in my integration.
Any suggestions?

Thanks
Best Answer chosen by hyj
PratikPratik (Salesforce Developers) 
Hi,

Please refer to this article:
https://help.salesforce.com/apex/HTViewSolution?urlname=Salesforce-disabling-SSL-3-0-encryption&language=en_US

Thanks,
Pratik

All Answers

PratikPratik (Salesforce Developers) 
Hi,

Please refer to this article:
https://help.salesforce.com/apex/HTViewSolution?urlname=Salesforce-disabling-SSL-3-0-encryption&language=en_US

Thanks,
Pratik
This was selected as the best answer
hyjhyj
Hi Pratik,

I've got the information from this page. Thank you very much.
So now, maybe I should find a Sandbox to have a test.
But I could not find the management page of Sandboxes in my user Setup. (Sandboxes or Data Management | Sandboxes in my Setup, referring to https://help.salesforce.com/apex/HTViewHelpDoc?id=create_test_instance.htm&language=en_US)
I could be sure that I have the configs listed in User Permissions Needed.
Is the Sandboxes page moved to another location? Or is this feaure disabled or limited?

Thanks
PratikPratik (Salesforce Developers) 
Hi Hyj,

The Data Management-> Sandboxes option will be available when you login to Production Instance.  

You can refer this:
https://help.salesforce.com/apex/HTViewHelpDoc?id=data_sandbox_create.htm&language=en_US

If you are still facing issues, post the comment.

Thanks,
Pratik