+ Start a Discussion
Pratik Sathaye 9Pratik Sathaye 9 

How Do I enable REST API for organization.

I am trying to use REST API for SalesForce for that I need to Enable REST API.

for that I went through Setup -> Manage Users -> Permission Sets -> Create New, but I am seeing Insufficient Privileges page.

I am using 30 days trial version.

How can I enable REST API ?

Thanks

Best Answer chosen by Pratik Sathaye 9
Swati GSwati G
API are not available in professional edition.

Here, what is documented,
Any functionality described in this guide is available if your organization has the API feature enabled. This feature is enabled by default for Performance, Unlimited, Enterprise, and Developer Editions. Some Professional Edition organizations may also have the API enabled. If you cannot access the features you see in this guide, contact Salesforce.

http://www.salesforce.com/developer/docs/api/Content/sforce_api_quickstart_intro.htm 

All Answers

Swati GSwati G
You dont need to enable that. Its enabled by default.
Pratik Sathaye 9Pratik Sathaye 9

I am getting response as 

{"message":"The REST API is not enabled for this Organization.","errorCode":"API_DISABLED_FOR_ORG"}

When I try to use REST API

Swati GSwati G
Go to the profile and check if API Enabled in true or false. 
Pratik Sathaye 9Pratik Sathaye 9
I am not seeing API Enabled Settings in my Profile.
Swati GSwati G
Which edition you are using? is it personal edition?
Pratik Sathaye 9Pratik Sathaye 9
I am using 30Days trial version and I guess its Professional Edition.
Swati GSwati G
API are not available in professional edition.

Here, what is documented,
Any functionality described in this guide is available if your organization has the API feature enabled. This feature is enabled by default for Performance, Unlimited, Enterprise, and Developer Editions. Some Professional Edition organizations may also have the API enabled. If you cannot access the features you see in this guide, contact Salesforce.

http://www.salesforce.com/developer/docs/api/Content/sforce_api_quickstart_intro.htm 
This was selected as the best answer
Pratik Sathaye 9Pratik Sathaye 9
Ok. So it seems I need developer edition to get things working. or will support guys help me enabling the REST API settings ?
Swati GSwati G
Its better to signup for developer edition.
Pratik Sathaye 9Pratik Sathaye 9
Ok. Thank you very much for your help :)
Umesh C 1Umesh C 1
Hello,

I have even signed for Developer Editiion Trial of 30 days but still I am getting same issue which says "API is not enabled for this Partner or Organization"
Alex HatcherAlex Hatcher
I realize this is a 2 year old thread, but guess what.  NO idea how to get this to work either.

30 days dev account,  follow the directions,  no "New" button.    go ask for help, they send me here. 
vinanth bvinanth b
Thats the same situation i have. Need to enable API
Sarah ReadSarah Read
I too am unclear as to how to enable REST API.  Pelase help.
Yuri Lopukhov 9Yuri Lopukhov 9
I am getting the same problem, could anyone solve this? Or I am just supposed to buy Enterprise version to develop api integration?
I can't even login on https://help.salesforce.com/support to contac support, it sends me back to login indefinitely.
I've spent too much time setting up simple oauth connection, bumping documentation typos and cryptic error messages just to find out on the last step that it is not enabled.
James WoodmancyJames Woodmancy
Can someone please help on this?  I have a developer account on a free trial and I do not see a Enable API option anywhere in settings -  people have suggested going to profiles -> enable API.  but its just not there... and I get an API error the REST API is not enabled for this Organization
RAJ RAMAN 1RAJ RAMAN 1
Folks- I have a indentical challenge- We are on trial account and trying to get access to REST API ; How can I activate REST API...why is Salesforce support not answering this question
Frederick BeckerFrederick Becker
See the following documentation: https://help.salesforce.com/articleView?id=bi_setup_rest_api_enable.htm&type=5
Eric Mann 10Eric Mann 10
Hi,
We are developing an integration with Salesforce and plan to become an app in the App Exchange. We've done the integration work, but have un-even results. Currently, we are getting the following error when our user tries to connect his/her account to our product (www.timeboostapp.com).

"The REST API is not enabled for this Organization.\\\",\\\"errorCode\\\":\\\"API_DISABLED_FOR_ORG\\\"}]\"\n}"}

A couple of questions:
1. How do we get REST API enabled? We bought the most basic Salesforce license ($300 per year for a single user). The account is under eric.mann@timeboostapp.com
2. By default, is the REST API something all users will need to enable or is there a way for us to work around this requirement to simplify the user experience?

Tks,
Eric
Michael Macho 1Michael Macho 1
I am also having the same issue.  I have seen all of the groups discussions from years ago.  so as of today we are running Salesforce Professional Eddition and when i go into setup and user roles to enable the API - Enable API there is no option to do this.  It does not show up.  

In reasing some other help articles, it says you have to have the API option enabled and to contact the SF Administrator, well thats me I am the SF Admin and cant seem to enable this option.  

I am trying to enable Trello Integration and it says that the Rest API needs to be enabled in salesforce.  It says that it works with Proffessional Eddition if the API is enabled.

Thoughts and Help?  
Paheerathan SelvarasaPaheerathan Selvarasa
  1. Click on Setup.
  2. Go to Manage Users and click Permission Sets.
  3. Select the Permission Set you're updating.
  4. Go to System and click System Permissions.
  5. Click Edit.
  6. Check the API Enabled box.
  7. Click Save.
inzmam HaQinzmam HaQ
Hey all just create developer account....its free and here you will got all you want.
https://developer.salesforce.com/signup
inzmam HaQinzmam HaQ
this option not availble with 30 days trial Account
Vinay PissalVinay Pissal
I have same issue...searched thru help.salesforce.com and couldent find option to enable REST API. I'm getting following error. Is there other option to access data from external app using REST APIs? 
{
  "message" : "The REST API is not enabled for this Organization.",
  "errorCode" : "API_DISABLED_FOR_ORG"
}