+ Start a Discussion
Ines CostaInes Costa 

Apex Test Executions Stuck - Cannot Run Tests - Developer Console also not working

Hi Everyone,

I am working on my sandbox on CS7 and all of a sudden my classes cannot be saved in the Developer console (they get stuck "saving"). If I go into the Salesforce Apex Test Execution page and try to run any tests these also get stuck and never finish.

Is this a known error? I am pressed with time and time is holding me back from testing and deploying a huge project.. so time is something i dont have

Many thanks in advance,
Ines

John PipkinJohn Pipkin
Ines, 

There is nothing listed on http://trust.salesforce.com/trust/status for cs7 instance. We are also using the CS7 instance and not running into any trouble. I would suggest opening a case with SFDC.
SarfarajSarfaraj
Hi Ines,

The maximum number of test classes that you can run per 24-hour period is the greater of 500 or 10 multiplied by the number of test classes in the organization. For sandbox and Developer Edition organizations, this limit is higher and is the greater of 500 or 20 multiplied by the number of test classes in the organization. 

Please check if you have exceeded your limit. In that case you have to wait till next day.

https://www.salesforce.com/us/developer/docs/apexcode/Content/apex_gov_limits.htm
https://www.salesforce.com/us/developer/docs/apexcode/Content/apex_testing_unit_tests_running.htm

--Akram
Ines CostaInes Costa

Hi Guys,
 

Unfortunately it cannot be the limits since i am testing one class and probably ran it 8 times before I got the errors. Then I tried deleting it and got the following error in the Developer Console.
error

I re-added it to the same name and I can now save but its still not running all my test classes or calculating the overall test coverage % correctly (now it says only 9%)

Ines
 

Ines CostaInes Costa
Raised a ticket with support asking for them to check why this happened and it got closed without any feedback and a "go post this to the Developer Boards". If you're "only a PAID customer" (not partner or premier) they just don't seem to care.