+ Start a Discussion
Chitral ChaddaChitral Chadda 

Java script pop up for IE version

i reuire that if IE version is 8 or less then it should display a pop up or a message
but its not working

<!DOCTYPE html>
<html>
<body>
<script>
function getInternetExplorerVersion() {
    var rv = -1; // Return value assumes failure.

    if (navigator.appName == 'Microsoft Internet Explorer') {
        var ua = navigator.userAgent;
        var re  = new RegExp("MSIE ([0-9]{1,}[\.0-9]{0,})");

        if (re.exec(ua) != null) {
            rv = parseFloat( RegExp.$1 );
        }
    }

    return rv;
}

function checkVersion() {
    var msg = "You're not using Internet Explorer.";
    var ver = getInternetExplorerVersion();

    if ( ver > -1 ) {
        if ( ver >= 9.0 ) {
            msg = "You're using a recent copy of Internet Explorer."
        }
        else {
            msg = "You should upgrade your copy of Internet Explorer.";
        }
    }
    alert(msg);
}
</script>
</body>
</html> 


no pop is displayed with this or message
BugudeBugude
Check the below link if it helps.
http://stackoverflow.com/questions/348202/display-a-message-when-a-browser-is-unsupported