+ Start a Discussion
Infuse MedicalInfuse Medical 

SFUserAccount - organizationName is nil

In an iOS app created using forceios, for SSO I am trying to establish a unique key using the SFIdentityData orgId and the SFUserAccount organizationName on the currentUser property of the SFUserAccountManager.  The orgId in the currentUser idData is set, but the organizationName on the actual user is nil.
Is this property not actually used? or is it tied to something else on the user in SalesForce that's just not set on the two instances I've tried.
akhilesh_sfdcakhilesh_sfdc
SFUserAccount only contains the information available via this api: https://help.salesforce.com/HTViewHelpDoc?id=remoteaccess_using_openid.htm

And it seems like the API is not returning the organization name and hence the variable is nil each time. We probably should hide this variable till API exposes this information. Apologies for the confusion.

Join our Mobile SDK community at http://sfdc.co/mobilesdkcommunity
Joseph NardoneJoseph Nardone
It has been almost 3 years and the organizationName property is still not populated but remains in the documentation.  Will this be fixed any time soon?