+ Start a Discussion
StardustStardust 

How can I correctly format the .csv file for update via Data Loader?(to be able to map fields)

I have a .csv file which contains all data needed for the update of the records of the custom object Signed Product (Product__c), whose Ids are listed in the first column. However, I am not able to map the fields, as all fields are detected as one - I login into the Data Loader, click on Update, select Signed Product in the "Select Salesforce Object:" list. Under browse, I select the appropriate .csv file. Then when I arrive to "Step 3: Mapping", the data loader detects only one column (where the header is the sequence of all headers of all columns contained in the file, separated by column ";"). Mapping is of course impossible! If I proceed with the update, I get the error file with the error "Id not specified in an update call", even though there is an ID for each record. The tool does not detect it due to the wrong mapping i.e. inability to map.

I think that this problem is connected with certain regional settings (e.g., German, Dutch) whereas the files can not be used as input .csv files for the Data Loader (I am using a German computer now, I know that there are issues with regional settings!). Should I use Notepad ++ to convert the format of the file? What should I do? I would need to get the steps necessary in order to convert the file into a .csv (comma delimited) format compatible with the tool.

Thanks a lot in advance,
& happy start of new year - looking forward to your kind replies
Ender_Ender_
Hi Stardust,

The dataloader currently recognizes "," as a delimeter (it may also recognize TAB).  If you could cover the semi-colon delimeters to commas in the comma separated file, then the Data Loader should work.   

Using excel or google docs to import the file, and then save the file as a .csv could be a quick way to do this.  

Hope this helps,

Lexi