+ Start a Discussion
Amit VaidyaAmit Vaidya 



Can any one help me on REQUEST_RUNNING_TOO_LONG error? Why we get this error and how we can resolve this error?

Thank you,

Note: I have received following error when i tried to run validation against production:
Running test: DemoTestClass, time spent on that test: 21750ms, total time spent running tests: 1764079ms. Error: REQUEST_RUNNING_TOO_LONG: Your request was running for too long, and has been stopped.
Shaijan ThomasShaijan Thomas
I can suggest you few things.
1. check any test class is having dependency (I mean any kind of dead lock).
2.if you are running any processes parllel stop that and try
3. verify all the custom setting values are uploaded correctly
4. if you have more the 2500 components. split it 2 or 3 packages and do it. ex.. labels, reports and dashbordes etc..
5. Hope you are using ANT. if not start using ANT
6. If its very urgent contact Salesforce. But future above case take into consideration.
Iqrar AhmedIqrar Ahmed
I hope following will  help you

Best Practices for Parallel Test ExecutionTests that are started from the Salesforce user interface (including the Developer Console) run in parallel. Parallel test execution can speed up test run time. Sometimes, parallel test execution results in data contention issues, and you can turn off parallel execution in those cases. In particular, data contention issues andUNABLE_TO_LOCK_ROW errors might occur in the following cases.When tests update the same records at the same time. Updating the same records typically occurs when tests don’t create their own data and turn off data isolation to access the organization’s data.
When a deadlock occurs in tests that are running in parallel and that try to create records with duplicate index field values. A deadlock occurs when two running tests are waiting for each other to roll back data, which happens if two tests insert records with the same unique index field values in different orders.You can prevent receiving those errors by turning off parallel test execution in the Salesforce user interface:From Setup, click Develop | Apex Test Execution | Options....
In the Apex Test Execution Options dialog, select Disable Parallel Apex Testing and than click OK.

Amit VaidyaAmit Vaidya
Hi Shaijan, Cloudy Rocky,

@Shaijan: Thanks for your suggestions. I am already using ANT for deployment. I am satisfying all suggestion that you have mentioned above just remain with the last suggestion. I will contact salesforce support for this. Thank you.

@Clody Rocky: On my org, the "Disable Parallel Apex Testing" is already checked. I think, it is busting somewhere else.

Thank you for your replies,