+ Start a Discussion
Big EarsBig Ears 

Developer Console - How do Checkpoints work?

Dear all,

I'm struggling with getting checkpoints to do anything for me in the Developer Console:
  1. I set the checkpoint in my test class
  2. I set the debugging logs to "finer" or "finset" on the apex code.
  3. I run the test class
  4. Nothing seems to appear in my checkpoints history.
User-added image

I've read these 2 pages in the help, but I don't know what I'm missing:
https://help.salesforce.com/apex/HTViewHelpDoc?id=code_dev_console_checkpoints_setting.htm&language=en_US (https://help.salesforce.com/apex/HTViewHelpDoc?id=code_dev_console_checkpoints_setting.htm&language=en_US)
https://help.salesforce.com/apex/HTViewHelpDoc?id=code_dev_console_tab_browser_logs.htm&language=en_US#set_log_levels (https://help.salesforce.com/apex/HTViewHelpDoc?id=code_dev_console_tab_browser_logs.htm&language=en_US#set_log_levels)

Every so often, I attempt to use the Developer Console, but I'm always immediately blocked by a lack of clarity in the functionality and documentation. I've sat through the webinars on the developer console, but can never replicate the behaviours that I see in their examples.
  • I can never find a useful stack trace (to see where methods have been called from) - Even if I open the "stack trace" view/window
  • I can never get checkpoints to work
  • The console slows down and becomes unusable very quickly
I'm not trying to post a grumpy post of all my grievances, but it would be good to get clarity if the issue is with me/my set-up or the console itself (or a mixture of the two).
ShashankShashank (Salesforce Developers) 
This is probably due to the fact that any DML as part of an apex test class run gets rolled back.
Big EarsBig Ears
Shashank,

Thanks for the response! So are checkpoints only used when invoking code in non-test situations? Isn't that potentially dangerous that you'd have to run "real" code in order to get to the root of what's going on? Is there any best practice guidance here?

Andy
ShashankShashank (Salesforce Developers) 
I found this which says it is indeed possible: http://salesforce.stackexchange.com/questions/46172/do-checkpoints-work-with-unit-tests
Big EarsBig Ears
Thanks Shashank. I've done everything that link has suggested and I'm still getting nothing. Thank you for your suggestion, though.
Andy Kallio 7Andy Kallio 7
I'm having the same problem, and just wondering you figured it out. 
Andy Kallio 7Andy Kallio 7
I just found it...the apex log level has to be set to fine or finest: https://help.salesforce.com/apex/HTViewHelpDoc?id=code_dev_console_checkpoints_setting.htm&language=en
Tena Wolver 23Tena Wolver 23
Mine doesn't work either and I have all the settings right
Ryan Adams 173Ryan Adams 173
I have set my apex log level to FINEST and despite searching all over I cannot find the heap or symbols of the checkpoint inspector:

The Checkpoint Inspector has two tabs: Heap and Symbols.
Heap—Displays all objects present in memory at the line of code where your checkpoint was executed.
Symbols—Displays all symbols in memory in tree view.

When I run the apex class no second tab opens.

Any ideas?
Dennis CooperDennis Cooper
Under the 'Debug' tab make sure 'Show my current checkpoints only' is unchecked.  I was not seeing any checkpoints in left checkpoint panel until i unchecked this option.  Once it was unchecked i was able to double click on a listed checkpoint in left checkpoint panel which opened up the heap/symbols panel.
Elio ShytiElio Shyti
Thank you Dennis,

I had the same problem, but your suggestion worked for me.
Paritosh BhatiaParitosh Bhatia
Thanks Dennis