+ Start a Discussion
Claudia JreissatiClaudia Jreissati 

Send an email action not showing in case feed

Hello,

After following the below steps and clicking save, the action "send an email" in the Publisher section doesn't show in the case feed of one of the support process. Any suggestions? Thanks

From Setup, click Customize | Cases | Page Layouts.
How you access the Case Feed Settings page depends on what kind of page layout you’re working with.

For a layout in the Case Page Layouts section, click Edit, and then click Feed View in the page layout editor.
For a layout in the Page Layouts for Case Feed Users section, click  [Case feed layout expand button]  and choose  Edit feed view. (This section appears only for organizations created before Spring ’14.)

Select Use Page Layout Editor to Configure Actions.
Click Save.
To access the page layout editor:

For a layout in the Case Page Layouts section, click Edit.
For a layout in the Page Layouts for Case Feed Users section, click  [Case feed layout expand button]  and choose Edit detail view. (This section appears only for organizations created before Spring ’14.)

In the page layout editor, click  [page layout editor change tool]  in the Actions in the Publisher section.
In the palette, click Actions.
Drag the actions you want to the Actions in the Publisher section. You can also drag actions to change the order in which they appear, and can drag off actions you don’t want. 
On the Case Feed page, up to approximately five or six actions are displayed in the publisher; the rest are included in the More drop-down list.
Click Save.

 
SonamSonam (Salesforce Developers) 
The above steps should get the action in the case feed ideally..is this happening for all the users or a specific user - just wondering if the user has access to create a task as send an email creates a task..
Ian StockIan Stock
Check the footnote in this article, might be what the issue is, but haven't tested it...
https://help.salesforce.com/apex/HTViewSolution?id=000194281&language=en_US
Caleb SidelCaleb Sidel
So reading this it appears that Send Email Actions are not supported within Case Feeds! Here's an idea to vote on https://success.salesforce.com/ideaView?id=08730000000l1tPAAQ&sort=2
Nathan Hembree 5Nathan Hembree 5
Not sure if this has been resolved, but for everyone out there banging their heads against the wall trying to find the Email action, you have to enable Email-to-case in order for the action to be available.
Richard Clarke - Artisan ConsultingRichard Clarke - Artisan Consulting
I solved this by moving the "Email" action into the Salesforce1 and Lightning Experience Actions area of the page layout.  So that means I have two there "Send Email" (which as per above does not appear in the Case Feed) and "Email" which does appear (and supports Quick Text)
Chase J. FriedmanChase J. Friedman
I'm not sure if this was updated at some point but you can no longer move the "Email" action into the Salesforce1 and Lightning Experience Actions area of the page layout. You can only put it in the Classifc layout. However doing so still solves the issue.
SFDC Admin 182SFDC Admin 182
Solution: https://help.salesforce.com/articleView?id=000248613&language=en_US&type=1

This behavior might be caused by the org Email access which is set to System Email Only.

Resolution: 
1. Click Setup | Administer | Email Administration | Deliverability
2. Set Access to Send Email (All Email Services) to All Email.
3. Click Save.
SuziSuzi
I have done all of these, and still can't get the capability to send email from case feed
 
Chase J. FriedmanChase J. Friedman
I haven’t double checked this but if you’re in a sandbox you might need to enable full email deliverability in setup. Just type “email deliver” and it should be the only result. Change it from system only to full. Chase J. Friedman
Suzi Simmons 30Suzi Simmons 30
Trailehead account
Email deliverability = All Email
email to case enabled
Case layout feed view email set up to use three fields
Quick actions in the Salesforce Classic Publisher shows email button (there are three available with the same name, I chose the one that has 
label: Email
Name: Case.SendEmail
Action type: Quick Action
Create Feed Item: Yes
There are two more, but didn't choose them.
I am missing something, can't see what


 
Chase J. FriedmanChase J. Friedman
Suzi, I just logged into my SF Trailhead playground and I'm going to say that you've either found a bug or a restriction. I've added my own custom global action for emails and it shows up on the Contact record but not on my Case record in my Page Layouts. 

I'll wager that this is a restriction by SF to prevent people from trying to run their own help desk out of their trailhead playground. Someone must have tried it in the past and now they blocked it for everyone. Sorry to be the bearer of bad news. 
Suzi Simmons 30Suzi Simmons 30
Don't be!  You validated what I have been trying to do, so now I don't have to continue to beat my head against the wall, or make an appointment with my optometrist!
Thanks
The PraxistThe Praxist
Suzi, In the quick actions for the Case page layout, when you hover over the email buttons, use the  one with name Case.Email. 
That resolved it for me. Thanks.
User-added image
Jorge Ponce 2Jorge Ponce 2
Hello Community

For me the issue was not having Case-to-Email enabled.  Once I enabled this, I was able to create and send emails through case feed quick action as metioned in Trailhead.  

Cheers
Arne van Veen 5Arne van Veen 5
Please check the following steps to enable this feature:
- Email deliverability = All Email
- Email to case enabled
- Create a new action on case, see this https://help.salesforce.com/articleView?id=case_interaction_send_email_quick_action_create.htm&type=5
- Drag the new action to the page layout

Good luck!
mophalon1.3932018715209495E12mophalon1.3932018715209495E12
Hi Suzi -- I was in the same boat and this solved the issue for me:  https://help.salesforce.com/articleView?id=000231283&type=1

Ensure "Enable Case Feed Actions and Feed Items" is enabled under support settings. To modify Support settings : Go | Setup | Customize | Cases | Support Settings.
phanidevphanidev
for me it worked when i added Send Email Action from the lightning quick action button on the page layout . it wasn't case.sendemail  just the sendemail one.
Deepika1007Deepika1007
Hi All,
Please find the step by step implementation.
https://deepikamatam.blogspot.com/2019/05/lightning-knowledge-insert-article.html
Scott G WaltersScott G Walters
For Case Emails...
Ensure the Deliverability is set to All Email
Enable Email-to-Case (and enable on demand if required),create routing address and verify
Ensure the org wide default email address is setup and verified.
Ensure the Open Activities and Activity History is on layout and can't hurt to ensure the Email (SendEmail) action is on the layout.
Ensure the profile has the Send Email permission