+ Start a Discussion
PaulBackhousePaulBackhouse 

ApproveContract permission

I have a permissionset pulled from an org. In it it lists the "ApproveContract" permission, set to true. When I try to sdeploy to another Org the deployment is rejected with
Error: Unknown user permission: ApproveContract
I assume that this permission is tied to an admin activated feature. What feature is it and how can I turn it off?

I can't find any documentation for this permission at all.
maryem bourhimaryem bourhi
I'm having the same issue when i try to deploy a Admin.profile 
James S. CloudAnswers.comJames S. CloudAnswers.com
Hi Guys,

I ran into the same issue as you and this page is the first item in Google, so I wanted to contribute back what I found:

This is a legacy contract approval function that is retiring as of Spring '15:
https://help.salesforce.com/HTViewSolution?id=000199129&language=en_US

This is a permission that I've found in older dev orgs but not newer ones presumably because the new orgs don't have this legacy setting.  Here it is in an old dev org (10 months old) under Permission Set > App Permissions.  I was not able to spot this setting in new dev orgs:

User-added image

I've manually removed the affected lines from my permission set in git/editor for the time being so I can deploy my code via api.
PaulBackhousePaulBackhouse
Yep, the only way avoid this is to carefully inspect the metadata and remove ApproveContract when you pull a permission set or profile with it in. I have a ticket open with Salesforce to have it stripped from my developer Org.