+ Start a Discussion
Connie SintosConnie Sintos 

Stuck on Challenge Module 2: Create an approval process that validates when a Prospect Account becomes a Customer (new error)

The challenge as follows:

For purposes of local regulation new customers must be approved by the legal team.

When an Account has the value of 'Prospect' in the Type field, a user will click the 'Submit for Approval' button to launch an approval process. The process will only happen if Type is 'Prospect' and there are more than 500 employees. Upon entry of the process, Type will become 'Pending' and be locked. If approved, Type will be set to 'Customer' and be unlocked. If not approved, Type will be set back to 'Prospect' and will be unlocked.

The Account object's Type field must have the following picklist values: Prospect, Customer, Pending. Before creating the approval process, verify the values in your Account object setup
The approval process name must be 'Approve New Account'.
When user click 'Submit for Approval', the approval must be processed if the Type field is set to 'Prospect' and the value of Employees is greater than 500.
Upon entering the approval process, set the Type field to 'Pending' and lock the record.
Normally the approver would be someone else. In this instance, assign yourself to be the approver.
If approved, set the Type field to 'Customer' and unlock the record.
If not approved, set the Type field back to 'Prospect', and unlock the record.

I am getting error message: Challenge not yet complete... here's what's wrong: 
The process did not set the correct Type value on submitting for approval

This are the steps I did:

Created approval process called Approve New Account
Criteria Account Type field equals Prospect and Account Employees field greater than 500
Select Assigned Approver - myself
Final Approval Actions - Update Type field to Customer
Final Rejection Actions - Update Type field to Prospect

What am I missing that I received the error message?  Please help.

Thanks.
Connie SintosConnie Sintos
disregard.  I was able to solve this.  I was missing the Initial Submission Actions.  I added the Field update Type field to Pending.

Thanks.
Joe SchmittJoe Schmitt
Connie, worked for me also.
Jorge BautistaJorge Bautista
thanks Connie, I forgot the same!
sunil mali 6sunil mali 6
Thank you Connie Sintos...It Worked :) 
WIN LAE AYEWIN LAE AYE
Thanks, I forgot this ones. It worked *)
sanjivani1.3943276802877876E12sanjivani1.3943276802877876E12
I have the fields set properly but still getting the error:

User-added image